| 1513 | Token Ring Extensions to the Remote Network Monitoring MIBS. Waldbusser | Historic | September 1993 |
| 2021 | Remote Network Monitoring Management Information Base Version 2 using SMIv2S. Waldbusser · obsoleted by RFC 4502 | Proposed Standard | January 1997 |
| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2074 | Remote Network Monitoring MIB Protocol IdentifiersA. Bierman, R. Iddon · obsoleted by RFC 2895 | Proposed Standard | January 1997 |
| 2233 | The Interfaces Group MIB using SMIv2K. McCloghrie, F. Kastenholz · obsoleted by RFC 2863 | Proposed Standard | November 1997 |
| 2330 | Framework for IP Performance MetricsV. Paxson, G. Almes, J. Mahdavi, M. Mathis | Informational | May 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2578 | Structure of Management Information Version 2 (SMIv2)K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2579 | Textual Conventions for SMIv2K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2580 | Conformance Statements for SMIv2K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2613 | Remote Network Monitoring MIB Extensions for Switched Networks Version 1.0R. Waterman, B. Lahaye, D. Romascanu, S. Waldbusser | Draft Standard | June 1999 |
| 2819 | Remote Network Monitoring Management Information BaseS. Waldbusser | Internet Standard | May 2000 |
| 2863 | The Interfaces Group MIBK. McCloghrie, F. Kastenholz | Draft Standard | June 2000 |
| 2895 | Remote Network Monitoring MIB Protocol Identifier ReferenceA. Bierman, C. Bucci, R. Iddon | Draft Standard | August 2000 |
| 2896 | Remote Network Monitoring MIB Protocol Identifier MacrosA. Bierman, C. Bucci, R. Iddon | Informational | August 2000 |
| 3144 | Remote Monitoring MIB Extensions for Interface Parameters MonitoringD. Romascanu | Proposed Standard | August 2001 |
| 3272 | Overview and Principles of Internet Traffic EngineeringD. Awduche, A. Chiu, A. Elwalid, I. Widjaja, X. Xiao · obsoleted by RFC 9522 | Informational | May 2002 |
| 3273 | Remote Network Monitoring Management Information Base for High Capacity NetworksS. Waldbusser | Proposed Standard | July 2002 |
| 3287 | Remote Monitoring MIB Extensions for Differentiated ServicesA. Bierman | Proposed Standard | July 2002 |
| 3395 | Remote Network Monitoring MIB Protocol Identifier Reference ExtensionsA. Bierman, C. Bucci, R. Dietz, A. Warth | Proposed Standard | September 2002 |
| 3410 | Introduction and Applicability Statements for Internet-Standard Management FrameworkJ. Case, R. Mundy, D. Partain, B. Stewart | Informational | December 2002 |
| 3434 | Remote Monitoring MIB Extensions for High Capacity AlarmsA. Bierman, K. McCloghrie | Proposed Standard | December 2002 |