| 821 | Simple Mail Transfer ProtocolJ. Postel · obsoleted by RFC 2821 | Internet Standard | August 1982 |
| 822 | STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGESD. Crocker · obsoleted by RFC 2822 | Internet Standard | August 1982 |
| 854 | Telnet Protocol SpecificationJ. Postel, J.K. Reynolds | Internet Standard | May 1983 |
| 977 | Network News Transfer ProtocolB. Kantor, P. Lapsley · obsoleted by RFC 3977 | Proposed Standard | February 1986 |
| 1510 | The Kerberos Network Authentication Service (V5)J. Kohl, C. Neuman · obsoleted by RFC 4120, RFC 6649 | Historic | September 1993 |
| 1704 | On Internet AuthenticationN. Haller, R. Atkinson | Informational | October 1994 |
| 1738 | Uniform Resource Locators (URL)T. Berners-Lee, L. Masinter, M. McCahill · obsoleted by RFC 4248, RFC 4266 | Proposed Standard | December 1994 |
| 1939 | Post Office Protocol - Version 3J. Myers, M. Rose | Internet Standard | May 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2222 | Simple Authentication and Security Layer (SASL)J. Myers · obsoleted by RFC 4422, RFC 4752 | Proposed Standard | October 1997 |
| 2223 | Instructions to RFC AuthorsJ. Postel, J. Reynolds · obsoleted by RFC 7322 | Informational | October 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2289 | A One-Time Password SystemN. Haller, C. Metz, P. Nesser, M. Straw | Internet Standard | February 1998 |
| 2338 | Virtual Router Redundancy ProtocolS. Knight, D. Weaver, D. Whipple, R. Hinden, D. Mitzel, P. Hunt, P. Higginson, M. Shand, A. Lindem · obsoleted by RFC 3768 | Proposed Standard | April 1998 |
| 2403 | The Use of HMAC-MD5-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2505 | Anti-Spam Recommendations for SMTP MTAsG. Lindberg | Best Current Practice | February 1999 |
| 2522 | Photuris: Session-Key Management ProtocolP. Karn, W. Simpson | Experimental | March 1999 |
| 2535 | Domain Name System Security ExtensionsD. Eastlake 3rd · obsoleted by RFC 4033, RFC 4034, RFC 4035 | Proposed Standard | March 1999 |
| 2554 | SMTP Service Extension for AuthenticationJ. Myers · obsoleted by RFC 4954 | Proposed Standard | March 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2633 | S/MIME Version 3 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 3851 | Proposed Standard | June 1999 |
| 2660 | The Secure HyperText Transfer ProtocolE. Rescorla, A. Schiffman | Historic | August 1999 |
| 2693 | SPKI Certificate TheoryC. Ellison, B. Frantz, B. Lampson, R. Rivest, B. Thomas, T. Ylonen | Experimental | September 1999 |
| 2743 | Generic Security Service Application Program Interface Version 2, Update 1J. Linn | Proposed Standard | January 2000 |
| 2817 | Upgrading to TLS Within HTTP/1.1R. Khare, S. Lawrence | Proposed Standard | May 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2946 | Telnet Data Encryption OptionT. Ts'o | Proposed Standard | September 2000 |
| 3207 | SMTP Service Extension for Secure SMTP over Transport Layer SecurityP. Hoffman | Proposed Standard | February 2002 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3546 | Transport Layer Security (TLS) ExtensionsS. Blake-Wilson, M. Nystrom, D. Hopwood, J. Mikkelsen, T. Wright · obsoleted by RFC 4366 | Proposed Standard | June 2003 |