| 821 | Simple Mail Transfer ProtocolJ. Postel · obsoleted by RFC 2821 | Internet Standard | August 1982 |
| 822 | STANDARD FOR THE FORMAT OF ARPA INTERNET TEXT MESSAGESD. Crocker · obsoleted by RFC 2822 | Internet Standard | August 1982 |
| 1064 | Interactive Mail Access Protocol: Version 2M.R. Crispin · obsoleted by RFC 1176, RFC 1203 | Unknown | July 1988 |
| 1176 | Interactive Mail Access Protocol: Version 2M.R. Crispin | Experimental | August 1990 |
| 1730 | Internet Message Access Protocol - Version 4M. Crispin · obsoleted by RFC 2060, RFC 2061 | Proposed Standard | December 1994 |
| 1732 | IMAP4 Compatibility with IMAP2 and IMAP2bisM. Crispin | Informational | December 1994 |
| 1733 | Distributed Electronic Mail Models in IMAP4M. Crispin | Informational | December 1994 |
| 1864 | The Content-MD5 Header FieldJ. Myers, M. Rose | Draft Standard | October 1995 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2047 | MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII TextK. Moore | Draft Standard | November 1996 |
| 2060 | Internet Message Access Protocol - Version 4rev1M. Crispin · obsoleted by RFC 3501 | Proposed Standard | December 1996 |
| 2061 | IMAP4 Compatibility with IMAP2bisM. Crispin | Informational | December 1996 |
| 2062 | Internet Message Access Protocol - Obsolete SyntaxM. Crispin | Informational | December 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2152 | UTF-7 A Mail-Safe Transformation Format of UnicodeD. Goldsmith, M. Davis | Informational | May 1997 |
| 2180 | IMAP4 Multi-Accessed Mailbox PracticeM. Gahrns | Informational | July 1997 |
| 2183 | Communicating Presentation Information in Internet Messages: The Content-Disposition Header FieldR. Troost, S. Dorner, K. Moore, Ed. | Proposed Standard | August 1997 |
| 2222 | Simple Authentication and Security Layer (SASL)J. Myers · obsoleted by RFC 4422, RFC 4752 | Proposed Standard | October 1997 |
| 2234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell · obsoleted by RFC 4234 | Proposed Standard | November 1997 |
| 2244 | ACAP -- Application Configuration Access ProtocolC. Newman, J. G. Myers | Proposed Standard | November 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2557 | MIME Encapsulation of Aggregate Documents, such as HTML (MHTML)J. Palme, A. Hopmann, N. Shelness | Proposed Standard | March 1999 |
| 2595 | Using TLS with IMAP, POP3 and ACAPC. Newman | Proposed Standard | June 1999 |
| 2683 | IMAP4 Implementation RecommendationsB. Leiba | Informational | September 1999 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2822 | Internet Message FormatP. Resnick, Ed. · obsoleted by RFC 5322 | Proposed Standard | April 2001 |
| 2831 | Using Digest Authentication as a SASL MechanismP. Leach, C. Newman · obsoleted by RFC 6331 | Historic | May 2000 |
| 2978 | IANA Charset Registration ProceduresN. Freed, J. Postel | Best Current Practice | October 2000 |
| 3066 | Tags for the Identification of LanguagesH. Alvestrand · obsoleted by RFC 4646, RFC 4647 | Best Current Practice | January 2001 |