| 9233 | Internationalized Domain Names for Applications 2008 (IDNA2008) and Unicode 12.0.0P. Fältström | Proposed Standard | March 2022 |
| 8881 | Network File System (NFS) Version 4 Minor Version 1 ProtocolD. Noveck, Ed., C. Lever | Proposed Standard | August 2020 |
| 8753 | Internationalized Domain Names for Applications (IDNA) Review for New Unicode VersionsJ. Klensin, P. Fältström | Proposed Standard | April 2020 |
| 8324 | DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?J. Klensin | Informational | February 2018 |
| 8264 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet | Proposed Standard | October 2017 |
| 7790 | Mapping Characters for Classes of the Preparation, Enforcement, and Comparison of Internationalized Strings (PRECIS)Y. Yoneya, T. Nemoto | Informational | February 2016 |
| 7564 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet · obsoleted by RFC 8264 | Proposed Standard | May 2015 |
| 6885 | Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)M. Blanchet, A. Sullivan | Informational | March 2013 |
| 6365 | Terminology Used in Internationalization in the IETFP. Hoffman, J. Klensin | Best Current Practice | September 2011 |
| 6122 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre · obsoleted by RFC 7622 | Proposed Standard | March 2011 |
| 5894 | Internationalized Domain Names for Applications (IDNA): Background, Explanation, and RationaleJ. Klensin | Informational | August 2010 |
| 5892 | The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)P. Faltstrom, Ed. | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5564 | Linguistic Guidelines for the Use of the Arabic Language in Internet DomainsA. El-Sherbiny, M. Farah, I. Oueichek, A. Al-Zoman | Informational | February 2010 |
| 5483 | ENUM Implementation Issues and ExperiencesL. Conroy, K. Fujiwara | Informational | March 2009 |
| 5456 | IAX: Inter-Asterisk eXchange Version 2M. Spencer, B. Capouch, E. Guy, Ed., F. Miller, K. Shumard | Informational | February 2010 |
| 5198 | Unicode Format for Network InterchangeJ. Klensin, M. Padlipsky | Proposed Standard | March 2008 |
| 5144 | A Domain Availability Check (DCHK) Registry Type for the Internet Registry Information Service (IRIS)A. Newton, M. Sanz | Proposed Standard | February 2008 |
| 4713 | Registration and Administration Recommendations for Chinese Domain NamesX. Lee, W. Mao, E. Chen, N. Hsu, J. Klensin | Informational | October 2006 |
| 4690 | Review and Recommendations for Internationalized Domain Names (IDNs)J. Klensin, P. Faltstrom, C. Karp, IAB | Informational | September 2006 |
| 4414 | An ENUM Registry Type for the Internet Registry Information Service (IRIS)A. Newton | Proposed Standard | February 2006 |
| 4343 | Domain Name System (DNS) Case Insensitivity ClarificationD. Eastlake 3rd | Proposed Standard | January 2006 |
| 4290 | Suggested Practices for Registration of Internationalized Domain Names (IDN)J. Klensin | Informational | December 2005 |
| 4185 | National and Local Characters for DNS Top Level Domain (TLD) NamesJ. Klensin | Informational | October 2005 |
| 4018 | Finding Internet Small Computer Systems Interface (iSCSI) Targets and Name Servers by Using Service Location Protocol version 2 (SLPv2)M. Bakke, J. Hufferd, K. Voruganti, M. Krueger, T. Sperry | Proposed Standard | May 2005 |
| 3987 | Internationalized Resource Identifiers (IRIs)M. Duerst, M. Suignard | Proposed Standard | January 2005 |
| 3982 | IRIS: A Domain Registry (dreg) Type for the Internet Registry Information Service (IRIS)A. Newton, M. Sanz | Proposed Standard | January 2005 |
| 3743 | Joint Engineering Team (JET) Guidelines for Internationalized Domain Names (IDN) Registration and Administration for Chinese, Japanese, and KoreanK. Konishi, K. Huang, H. Qian, Y. Ko | Informational | April 2004 |
| 3722 | String Profile for Internet Small Computer Systems Interface (iSCSI) NamesM. Bakke | Proposed Standard | April 2004 |
| 3696 | Application Techniques for Checking and Transformation of NamesJ. Klensin | Informational | February 2004 |