| 625 | On-line hostnames serviceM.D. Kudlick, E.J. Feinler | Unknown | March 1974 |
| 734 | SUPDUP ProtocolM.R. Crispin | Historic | October 1977 |
| 742 | NAME/FINGER ProtocolK. Harrenstien · obsoleted by RFC 1194, RFC 1196, RFC 1288 | Unknown | December 1977 |
| 811 | Hostnames ServerK. Harrenstien, V. White, E.J. Feinler · obsoleted by RFC 953 | Unknown | March 1982 |
| 819 | The Domain Naming Convention for Internet User ApplicationsZ. Su, J. Postel | Unknown | August 1982 |
| 830 | Distributed system for Internet name serviceZ. Su | Unknown | October 1982 |
| 854 | Telnet Protocol SpecificationJ. Postel, J.K. Reynolds | Internet Standard | May 1983 |
| 855 | Telnet Option SpecificationsJ. Postel, J.K. Reynolds | Internet Standard | May 1983 |
| 882 | Domain names: Concepts and facilitiesP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | November 1983 |
| 883 | Domain names: Implementation specificationP. Mockapetris · obsoleted by RFC 1034, RFC 1035 | Unknown | November 1983 |
| 952 | DoD Internet host table specificationK. Harrenstien, M.K. Stahl, E.J. Feinler | Unknown | October 1985 |
| 953 | Hostname ServerK. Harrenstien, M.K. Stahl, E.J. Feinler | Historic | October 1985 |
| 954 | NICNAME/WHOISK. Harrenstien, M.K. Stahl, E.J. Feinler · obsoleted by RFC 3912 | Draft Standard | October 1985 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1288 | The Finger User Information ProtocolD. Zimmerman | Draft Standard | December 1991 |
| 1519 | Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation StrategyV. Fuller, T. Li, J. Yu, K. Varadhan · obsoleted by RFC 4632 | Proposed Standard | September 1993 |
| 1591 | Domain Name System Structure and DelegationJ. Postel | Informational | March 1994 |
| 1834 | Whois and Network Information Lookup Service, Whois++J. Gargano, K. Weiss | Informational | August 1995 |
| 1913 | Architecture of the Whois++ Index ServiceC. Weider, J. Fullton, S. Spero | Historic | February 1996 |
| 2167 | Referral Whois (RWhois) Protocol V1.5S. Williamson, M. Kosters, D. Blacka, J. Singh, K. Zeilstra | Informational | June 1997 |
| 2181 | Clarifications to the DNS SpecificationR. Elz, R. Bush | Proposed Standard | July 1997 |
| 2295 | Transparent Content Negotiation in HTTPK. Holtman, A. Mutz | Experimental | March 1998 |
| 2317 | Classless IN-ADDR.ARPA delegationH. Eidnes, G. de Groot, P. Vixie | Best Current Practice | March 1998 |
| 2396 | Uniform Resource Identifiers (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter · obsoleted by RFC 3986 | Draft Standard | August 1998 |
| 2608 | Service Location Protocol, Version 2E. Guttman, C. Perkins, J. Veizades, M. Day | Proposed Standard | June 1999 |
| 2671 | Extension Mechanisms for DNS (EDNS0)P. Vixie · obsoleted by RFC 6891 | Proposed Standard | August 1999 |
| 2825 | A Tangled Web: Issues of I18N, Domain Names, and the Other Internet protocolsIAB, L. Daigle, Ed. | Informational | May 2000 |
| 2826 | IAB Technical Comment on the Unique DNS RootInternet Architecture Board | Informational | May 2000 |
| 2915 | The Naming Authority Pointer (NAPTR) DNS Resource RecordM. Mealling, R. Daniel · obsoleted by RFC 3401, RFC 3402, RFC 3403, RFC 3404 | Proposed Standard | September 2000 |
| 2957 | The application/whoispp-query Content-TypeL. Daigle, P. Faltstrom | Informational | October 2000 |
| 2958 | The application/whoispp-response Content-typeL. Daigle, P. Faltstrom | Informational | October 2000 |
| 2972 | Context and Goals for Common Name ResolutionN. Popp, M. Mealling, L. Masinter, K. Sollins | Informational | October 2000 |
| 3305 | Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and RecommendationsM. Mealling, Ed., R. Denenberg, Ed. | Informational | August 2002 |
| 3401 | Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDSM. Mealling | Informational | October 2002 |
| 3402 | Dynamic Delegation Discovery System (DDDS) Part Two: The AlgorithmM. Mealling | Proposed Standard | October 2002 |
| 3403 | Dynamic Delegation Discovery System (DDDS) Part Three: The Domain Name System (DNS) DatabaseM. Mealling | Proposed Standard | October 2002 |
| 3425 | Obsoleting IQUERYD. Lawrence | Proposed Standard | November 2002 |
| 3439 | Some Internet Architectural Guidelines and PhilosophyR. Bush, D. Meyer | Informational | December 2002 |
| 3454 | Preparation of Internationalized Strings ("stringprep")P. Hoffman, M. Blanchet · obsoleted by RFC 7564 | Proposed Standard | January 2003 |