| 8458 | Using National Bibliography Numbers as Uniform Resource NamesJ. Hakala | Informational | October 2018 |
| 8254 | Uniform Resource Name (URN) Namespace Registration TransitionJ. Klensin, J. Hakala | Proposed Standard | October 2017 |
| 8141 | Uniform Resource Names (URNs)P. Saint-Andre, J. Klensin | Proposed Standard | April 2017 |
| 8107 | Advertising Digital Identifier (Ad-ID) URN Namespace DefinitionJ. Wold | Informational | March 2017 |
| 8069 | URN Namespace for IEEEA. Thomas | Informational | February 2017 |
| 8057 | Uniform Resource Name (URN) Namespaces for Broadband ForumB. Stark, D. Sinicrope, W. Lupton | Informational | January 2017 |
| 7972 | Entertainment Identifier Registry (EIDR) URN Namespace DefinitionP. Lemieux | Informational | September 2016 |
| 7853 | A URN Namespace for GlobusS. Martin, S. Tuecke, B. McCollam, M. Lidman | Informational | May 2016 |
| 7738 | A Uniform Resource Name (URN) Namespace for the Consultative Committee for Space Data Systems (CCSDS)M. Blanchet, A. Schiltknecht, P. Shames | Informational | January 2016 |
| 7595 | Guidelines and Registration Procedures for URI SchemesD. Thaler, Ed., T. Hansen, T. Hardie | Best Current Practice | June 2015 |
| 7528 | A Uniform Resource Name (URN) Namespace for the Hybrid Broadcast Broadband TV (HbbTV) AssociationP. Higgs, J. Piesing | Informational | April 2015 |
| 7467 | URN Namespace for the North Atlantic Treaty Organization (NATO)A. Murdock | Informational | April 2015 |
| 7462 | URNs for the Alert-Info Header Field of the Session Initiation Protocol (SIP)L. Liess, Ed., R. Jesske, A. Johnston, D. Worley, P. Kyzivat | Proposed Standard | March 2015 |
| 7302 | Entertainment Identifier Registry (EIDR) URN Namespace DefinitionP. Lemieux · obsoleted by RFC 7972 | Informational | July 2014 |
| 7254 | A Uniform Resource Name Namespace for the Global System for Mobile Communications Association (GSMA) and the International Mobile station Equipment Identity (IMEI)M. Montemurro, Ed., A. Allen, D. McDonald, P. Gosden | Informational | May 2014 |
| 7207 | A Uniform Resource Name (URN) Namespace for Eurosystem MessagingM. Ortseifen, G. Dickfeld | Informational | April 2014 |
| 6963 | A Uniform Resource Name (URN) Namespace for ExamplesP. Saint-Andre | Best Current Practice | May 2013 |
| 6933 | Entity MIB (Version 4)A. Bierman, D. Romascanu, J. Quittek, M. Chandramouli | Proposed Standard | May 2013 |
| 6893 | A Uniform Resource Name (URN) Namespace for the Open IPTV Forum (OIPF)P. Higgs, P. Szucs | Informational | March 2013 |
| 6648 | Deprecating the "X-" Prefix and Similar Constructs in Application ProtocolsP. Saint-Andre, D. Crocker, M. Nottingham | Best Current Practice | June 2012 |
| 6453 | A URN Namespace for the Open Grid Forum (OGF)F. Dijkstra, R. Hughes-Jones | Informational | December 2011 |
| 6350 | vCard Format SpecificationS. Perreault | Proposed Standard | August 2011 |
| 6338 | Definition of a Uniform Resource Name (URN) Namespace for the Schema for Academia (SCHAC)V. Giralt, R. McDuff | Informational | August 2011 |
| 6289 | A Uniform Resource Name (URN) Namespace for CableLabsE. Cardona, S. Channabasappa, J-F. Mule | Informational | June 2011 |
| 6288 | URN Namespace for the Defence Geospatial Information Working Group (DGIWG)C. Reed | Informational | August 2011 |
| 6061 | Uniform Resource Name (URN) Namespace for the National Emergency Number Association (NENA)B. Rosen | Informational | January 2011 |
| 6050 | A Session Initiation Protocol (SIP) Extension for the Identification of ServicesK. Drage | Informational | November 2010 |
| 5328 | A Uniform Resource Name (URN) Namespace for the Digital Video Broadcasting Project (DVB)A. Adolf, P. MacAvock | Informational | September 2008 |
| 5279 | A Uniform Resource Name (URN) Namespace for the 3rd Generation Partnership Project (3GPP)A. Monrad, S. Loreto | Informational | July 2008 |
| 5165 | A Uniform Resource Name (URN) Namespace for the Open Geospatial Consortium (OGC)C. Reed | Informational | April 2008 |
| 5141 | A Uniform Resource Name (URN) Namespace for the International Organization for Standardization (ISO)J. Goodwin, H. Apel | Informational | March 2008 |
| 5138 | A Uniform Resource Name (URN) Namespace for the Commission for the Management and Application of Geoscience Information (CGI)S. Cox | Informational | February 2008 |
| 5119 | A Uniform Resource Name (URN) Namespace for the Society of Motion Picture and Television Engineers (SMPTE)T. Edwards | Informational | February 2008 |
| 5031 | A Uniform Resource Name (URN) for Emergency and Other Well-Known ServicesH. Schulzrinne | Proposed Standard | January 2008 |
| 4926 | A URN Namespace for GEANTT. Kalin, M. Molina | Informational | July 2007 |
| 4854 | A Uniform Resource Name (URN) Namespace for Extensions to the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre | Informational | April 2007 |
| 4730 | A Session Initiation Protocol (SIP) Event Package for Key Press Stimulus (KPML)E. Burger, M. Dolly | Proposed Standard | November 2006 |
| 4729 | A Uniform Resource Name (URN) Namespace for the Near Field Communication (NFC) ForumM. Abel | Informational | November 2006 |
| 4688 | A Uniform Resource Name (URN) Namespace for Aerospace and Defence Industries Association of Europe (ASD) Specification 1000DS. Rushing | Informational | October 2006 |
| 4617 | A Uniform Resource Name (URN) Formal Namespace for the Latvian National Government Integration ProjectJ. Kornijenko | Informational | August 2006 |
| 4395 | Guidelines and Registration Procedures for New URI SchemesT. Hansen, T. Hardie, L. Masinter · obsoleted by RFC 7595 | Best Current Practice | February 2006 |
| 4358 | A Uniform Resource Name (URN) Namespace for the Open Mobile Alliance (OMA)D. Smith | Informational | January 2006 |
| 4350 | A Uniform Resource Name (URN) Formal Namespace for the New Zealand GovernmentF. Hendrikx, C. Wallis | Informational | February 2006 |
| 4246 | International Standard Audiovisual Number (ISAN) URN DefinitionM. Dolan | Informational | February 2006 |
| 4198 | A Uniform Resource Name (URN) Namespace for Federated ContentD. Tessman | Informational | November 2005 |
| 4179 | Using Universal Content Identifier (UCI) as Uniform Resource Names (URN)S. Kang | Informational | October 2005 |
| 4152 | A Uniform Resource Name (URN) Namespace for the Common Language Equipment Identifier (CLEI) CodeK. Tesink, R. Fox | Informational | August 2005 |
| 4133 | Entity MIB (Version 3)A. Bierman, K. McCloghrie · obsoleted by RFC 6933 | Proposed Standard | August 2005 |
| 3937 | A Uniform Resource Name (URN) Namespace for the International Press Telecommunications Council (IPTC)M. Steidl | Informational | November 2004 |
| 3616 | A Uniform Resource Name (URN) Namespace for Foundation for Intelligent Physical Agents (FIPA)F. Bellifemine, I. Constantinescu, S. Willmott | Informational | September 2003 |
| 3615 | A Uniform Resource Name (URN) Namespace for SWIFT Financial MessagingJ. Gustin, A. Goyens | Informational | September 2003 |
| 3553 | An IETF URN Sub-namespace for Registered Protocol ParametersM. Mealling, L. Masinter, T. Hardie, G. Klyne | Best Current Practice | June 2003 |