| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1350 | The TFTP Protocol (Revision 2)K. Sollins | Internet Standard | July 1992 |
| 1435 | IESG Advice from Experience with Path MTU DiscoveryS. Knowles | Informational | March 1993 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2488 | Enhancing TCP Over Satellite Channels using Standard MechanismsM. Allman, D. Glover, L. Sanchez | Best Current Practice | January 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2757 | Long Thin NetworksG. Montenegro, S. Dawkins, M. Kojo, V. Magret, N. Vaidya | Informational | January 2000 |
| 2760 | Ongoing TCP Research Related to SatellitesM. Allman, Ed., S. Dawkins, D. Glover, J. Griner, D. Tran, T. Henderson, J. Heidemann, J. Touch, H. Kruse, S. Ostermann, K. Scott, J. Semke | Informational | February 2000 |
| 2960 | Stream Control Transmission ProtocolR. Stewart, Q. Xie, K. Morneault, C. Sharp, H. Schwarzbauer, T. Taylor, I. Rytina, M. Kalla, L. Zhang, V. Paxson · obsoleted by RFC 4960 | Proposed Standard | October 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |
| 3260 | New Terminology and Clarifications for DiffservD. Grossman | Informational | April 2002 |