| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1886 | DNS Extensions to support IP version 6S. Thomson, C. Huitema · obsoleted by RFC 3596 | Proposed Standard | December 1995 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2401 | Security Architecture for the Internet ProtocolS. Kent, R. Atkinson · obsoleted by RFC 4301 | Proposed Standard | November 1998 |
| 2402 | IP Authentication HeaderS. Kent, R. Atkinson · obsoleted by RFC 4302, RFC 4305 | Proposed Standard | November 1998 |
| 2403 | The Use of HMAC-MD5-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2404 | The Use of HMAC-SHA-1-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2405 | The ESP DES-CBC Cipher Algorithm With Explicit IVC. Madson, N. Doraswamy | Proposed Standard | November 1998 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2407 | The Internet IP Security Domain of Interpretation for ISAKMPD. Piper · obsoleted by RFC 4306 | Historic | November 1998 |
| 2408 | Internet Security Association and Key Management Protocol (ISAKMP)D. Maughan, M. Schertler, M. Schneider, J. Turner · obsoleted by RFC 4306 | Historic | November 1998 |
| 2409 | The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306 | Historic | November 1998 |
| 2410 | The NULL Encryption Algorithm and Its Use With IPsecR. Glenn, S. Kent | Proposed Standard | November 1998 |
| 2451 | The ESP CBC-Mode Cipher AlgorithmsR. Pereira, R. Adams | Proposed Standard | November 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2461 | Neighbor Discovery for IP Version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson · obsoleted by RFC 4861 | Draft Standard | December 1998 |
| 2462 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten · obsoleted by RFC 4862 | Draft Standard | December 1998 |
| 2463 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering · obsoleted by RFC 4443 | Draft Standard | December 1998 |
| 2472 | IP Version 6 over PPPD. Haskin, E. Allen · obsoleted by RFC 5072, RFC 5172 | Proposed Standard | December 1998 |
| 2473 | Generic Packet Tunneling in IPv6 SpecificationA. Conta, S. Deering | Proposed Standard | December 1998 |
| 2529 | Transmission of IPv6 over IPv4 Domains without Explicit TunnelsB. Carpenter, C. Jung | Proposed Standard | March 1999 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2711 | IPv6 Router Alert OptionC. Partridge, A. Jackson | Proposed Standard | October 1999 |
| 2874 | DNS Extensions to Support IPv6 Address Aggregation and RenumberingM. Crawford, C. Huitema | Historic | July 2000 |
| 3041 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves · obsoleted by RFC 4941 | Proposed Standard | January 2001 |
| 3152 | Delegation of IP6.ARPAR. Bush · obsoleted by RFC 3596 | Best Current Practice | August 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |
| 3314 | Recommendations for IPv6 in Third Generation Partnership Project (3GPP) StandardsM. Wasserman, Ed. | Informational | September 2002 |
| 3481 | TCP over Second (2.5G) and Third (3G) Generation Wireless NetworksH. Inamura, Ed., G. Montenegro, Ed., R. Ludwig, A. Gurtov, F. Khafizov | Best Current Practice | February 2003 |
| 3484 | Default Address Selection for Internet Protocol version 6 (IPv6)R. Draves · obsoleted by RFC 6724 | Proposed Standard | March 2003 |
| 3513 | Internet Protocol Version 6 (IPv6) Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 4291 | Proposed Standard | April 2003 |