| 9710 | Simple Fixes to the IP Flow Information Export (IPFIX) Entities IANA RegistryM. Boucadair, B. Claise | Proposed Standard | February 2025 |
| 9065 | Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport ProtocolsG. Fairhurst, C. Perkins | Informational | July 2021 |
| 8799 | Limited Domains and Internet ProtocolsB. Carpenter, B. Liu | Informational | July 2020 |
| 8558 | Transport Protocol Path SignalsT. Hardie, Ed. | Informational | April 2019 |
| 8517 | An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator PerspectiveD. Dolson, Ed., J. Snellman, M. Boucadair, Ed., C. Jacquenet | Informational | February 2019 |
| 8158 | IP Flow Information Export (IPFIX) Information Elements for Logging NAT EventsS. Sivakumar, R. Penno | Proposed Standard | December 2017 |
| 8003 | Host Identity Protocol (HIP) Registration ExtensionJ. Laganier, L. Eggert | Proposed Standard | October 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 7663 | Report from the IAB Workshop on Stack Evolution in a Middlebox Internet (SEMI)B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | October 2015 |
| 7452 | Architectural Considerations in Smart Object NetworkingH. Tschofenig, J. Arkko, D. Thaler, D. McPherson | Informational | March 2015 |
| 7199 | Location Configuration Extensions for Policy ManagementR. Barnes, M. Thomson, J. Winterbottom, H. Tschofenig | Proposed Standard | April 2014 |
| 7012 | Information Model for IP Flow Information Export (IPFIX)B. Claise, Ed., B. Trammell, Ed. | Proposed Standard | September 2013 |
| 6589 | Considerations for Transitioning Content to IPv6J. Livingood | Informational | April 2012 |
| 6182 | Architectural Guidelines for Multipath TCP DevelopmentA. Ford, C. Raiciu, M. Handley, S. Barre, J. Iyengar | Informational | March 2011 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 5973 | NAT/Firewall NSIS Signaling Layer Protocol (NSLP)M. Stiemerling, H. Tschofenig, C. Aoun, E. Davies | Experimental | October 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5595 | The Datagram Congestion Control Protocol (DCCP) Service CodesG. Fairhurst | Proposed Standard | September 2009 |
| 5207 | NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. Eggert | Informational | April 2008 |
| 5203 | Host Identity Protocol (HIP) Registration ExtensionJ. Laganier, T. Koponen, L. Eggert · obsoleted by RFC 8003 | Experimental | April 2008 |
| 5190 | Definitions of Managed Objects for Middlebox CommunicationJ. Quittek, M. Stiemerling, P. Srisuresh | Proposed Standard | March 2008 |
| 5153 | IP Flow Information Export (IPFIX) Implementation GuidelinesE. Boschi, L. Mark, J. Quittek, M. Stiemerling, P. Aitken | Informational | April 2008 |
| 5103 | Bidirectional Flow Export Using IP Flow Information Export (IPFIX)B. Trammell, E. Boschi | Proposed Standard | January 2008 |
| 5102 | Information Model for IP Flow Information ExportJ. Quittek, S. Bryant, B. Claise, P. Aitken, J. Meyer · obsoleted by RFC 7012 | Proposed Standard | January 2008 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 4540 | NEC's Simple Middlebox Configuration (SIMCO) Protocol Version 3.0M. Stiemerling, J. Quittek, C. Cadar | Experimental | May 2006 |
| 3917 | Requirements for IP Flow Information Export (IPFIX)J. Quittek, T. Zseby, B. Claise, S. Zander | Informational | October 2004 |
| 3869 | IAB Concerns and Recommendations Regarding Internet Research and EvolutionR. Atkinson, Ed., S. Floyd, Ed., Internet Architecture Board | Informational | August 2004 |
| 3726 | Requirements for Signaling ProtocolsM. Brunner, Ed. | Informational | April 2004 |
| 3724 | The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet ArchitectureJ. Kempf, Ed., R. Austein, Ed., IAB | Informational | March 2004 |
| 3426 | General Architectural and Policy ConsiderationsS. Floyd | Informational | November 2002 |