| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 925 | Multi-LAN address resolutionJ. Postel | Unknown | October 1984 |
| 1144 | Compressing TCP/IP Headers for Low-Speed Serial LinksV. Jacobson | Proposed Standard | February 1990 |
| 1256 | ICMP Router Discovery MessagesS. Deering, Ed. | Proposed Standard | September 1991 |
| 1305 | Network Time Protocol (Version 3) Specification, Implementation and AnalysisD. Mills · obsoleted by RFC 5905 | Historic | March 1992 |
| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 1332 | The PPP Internet Protocol Control Protocol (IPCP)G. McGregor | Proposed Standard | May 1992 |
| 1701 | Generic Routing Encapsulation (GRE)S. Hanks, T. Li, D. Farinacci, P. Traina | Informational | October 1994 |
| 1750 | Randomness Recommendations for SecurityD. Eastlake 3rd, S. Crocker, J. Schiller · obsoleted by RFC 4086 | Informational | December 1994 |
| 2002 | IP Mobility SupportC. Perkins, Ed. · obsoleted by RFC 3220 | Proposed Standard | October 1996 |
| 2003 | IP Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2004 | Minimal Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2005 | Applicability Statement for IP Mobility SupportJ. Solomon | Proposed Standard | October 1996 |
| 2006 | The Definitions of Managed Objects for IP Mobility Support using SMIv2D. Cong, M. Hamlen, C. Perkins | Proposed Standard | October 1996 |
| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2290 | Mobile-IPv4 Configuration Option for PPP IPCPJ. Solomon, S. Glass | Proposed Standard | February 1998 |
| 2356 | Sun's SKIP Firewall Traversal for Mobile IPG. Montenegro, V. Gupta | Informational | June 1998 |
| 2402 | IP Authentication HeaderS. Kent, R. Atkinson · obsoleted by RFC 4302, RFC 4305 | Proposed Standard | November 1998 |
| 2434 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 5226 | Best Current Practice | October 1998 |
| 2757 | Long Thin NetworksG. Montenegro, S. Dawkins, M. Kojo, V. Magret, N. Vaidya | Informational | January 2000 |
| 2794 | Mobile IP Network Access Identifier Extension for IPv4P. Calhoun, C. Perkins | Proposed Standard | March 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 2863 | The Interfaces Group MIBK. McCloghrie, F. Kastenholz | Draft Standard | June 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3012 | Mobile IPv4 Challenge/Response ExtensionsC. Perkins, P. Calhoun · obsoleted by RFC 4721 | Proposed Standard | November 2000 |
| 3024 | Reverse Tunneling for Mobile IP, revisedG. Montenegro, Ed. | Proposed Standard | January 2001 |
| 3115 | Mobile IP Vendor/Organization-Specific ExtensionsG. Dommety, K. Leung | Proposed Standard | April 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |