| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2140 | TCP Control Block InterdependenceJ. Touch · obsoleted by RFC 9040 | Informational | April 1997 |
| 2309 | Recommendations on Queue Management and Congestion Avoidance in the InternetB. Braden, D. Clark, J. Crowcroft, B. Davie, S. Deering, D. Estrin, S. Floyd, V. Jacobson, G. Minshall, C. Partridge, L. Peterson, K. Ramakrishnan, S. Shenker, J. Wroclawski, L. Zhang · obsoleted by RFC 7567 | Informational | April 1998 |
| 2481 | A Proposal to add Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd · obsoleted by RFC 3168 | Experimental | January 1999 |
| 2488 | Enhancing TCP Over Satellite Channels using Standard MechanismsM. Allman, D. Glover, L. Sanchez | Best Current Practice | January 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2582 | The NewReno Modification to TCP's Fast Recovery AlgorithmS. Floyd, T. Henderson · obsoleted by RFC 3782 | Experimental | April 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2757 | Long Thin NetworksG. Montenegro, S. Dawkins, M. Kojo, V. Magret, N. Vaidya | Informational | January 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2861 | TCP Congestion Window ValidationM. Handley, J. Padhye, S. Floyd · obsoleted by RFC 7661 | Historic | June 2000 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 2923 | TCP Problems with Path MTU DiscoveryK. Lahey | Informational | September 2000 |
| 3042 | Enhancing TCP's Loss Recovery Using Limited TransmitM. Allman, H. Balakrishnan, S. Floyd | Proposed Standard | January 2001 |
| 3124 | The Congestion ManagerH. Balakrishnan, S. Seshan | Proposed Standard | June 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |