| 9765 | RADIUS/1.1: Leveraging Application-Layer Protocol Negotiation (ALPN) to Remove MD5A. DeKok | Experimental | April 2025 |
| 9099 | Operational Security Considerations for IPv6 NetworksÉ. Vyncke, K. Chittimaneni, M. Kaeo, E. Rey | Informational | August 2021 |
| 8559 | Dynamic Authorization Proxying in the Remote Authentication Dial-In User Service (RADIUS) ProtocolA. DeKok, J. Korhonen | Proposed Standard | April 2019 |
| 8506 | Diameter Credit-Control ApplicationL. Bertz, Ed., D. Dolson, Ed., Y. Lifshitz, Ed. | Proposed Standard | March 2019 |
| 8501 | Reverse DNS in IPv6 for Internet Service ProvidersL. Howard | Informational | November 2018 |
| 8045 | RADIUS Extensions for IP Port Configuration and ReportingD. Cheng, J. Korhonen, M. Boucadair, S. Sivakumar | Proposed Standard | January 2017 |
| 7585 | Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)S. Winter, M. McCauley | Experimental | October 2015 |
| 7576 | General Gap Analysis for Autonomic NetworkingS. Jiang, B. Carpenter, M. Behringer | Informational | June 2015 |
| 7542 | The Network Access IdentifierA. DeKok | Proposed Standard | May 2015 |
| 7499 | Support of Fragmentation of RADIUS PacketsA. Perez-Mendez, Ed., R. Marin-Lopez, F. Pereniguez-Garcia, G. Lopez-Millan, D. Lopez, A. DeKok | Experimental | April 2015 |
| 7360 | Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUSA. DeKok | Experimental | September 2014 |
| 7155 | Diameter Network Access Server ApplicationG. Zorn, Ed. | Proposed Standard | April 2014 |
| 6929 | Remote Authentication Dial In User Service (RADIUS) Protocol ExtensionsA. DeKok, A. Lior | Proposed Standard | April 2013 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6632 | An Overview of the IETF Network Management StandardsM. Ersue, Ed., B. Claise | Informational | June 2012 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6613 | RADIUS over TCPA. DeKok | Experimental | May 2012 |
| 6572 | RADIUS Support for Proxy Mobile IPv6F. Xia, B. Sarikaya, J. Korhonen, Ed., S. Gundavelli, D. Damic | Proposed Standard | June 2012 |
| 6218 | Cisco Vendor-Specific RADIUS Attributes for the Delivery of Keying MaterialG. Zorn, T. Zhang, J. Walker, J. Salowey | Informational | April 2011 |
| 6158 | RADIUS Design GuidelinesA. DeKok, Ed., G. Weber | Best Current Practice | March 2011 |
| 5997 | Use of Status-Server Packets in the Remote Authentication Dial In User Service (RADIUS) ProtocolA. DeKok | Informational | August 2010 |
| 5607 | Remote Authentication Dial-In User Service (RADIUS) Authorization for Network Access Server (NAS) ManagementD. Nelson, G. Weber | Proposed Standard | July 2009 |
| 5580 | Carrying Location Objects in RADIUS and DiameterH. Tschofenig, Ed., F. Adrangi, M. Jones, A. Lior, B. Aboba | Proposed Standard | August 2009 |
| 5176 | Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)M. Chiba, G. Dommety, M. Eklund, D. Mitton, B. Aboba | Informational | January 2008 |
| 5080 | Common Remote Authentication Dial In User Service (RADIUS) Implementation Issues and Suggested FixesD. Nelson, A. DeKok | Proposed Standard | December 2007 |
| 5030 | Mobile IPv4 RADIUS RequirementsM. Nakhjiri, Ed., K. Chowdhury, A. Lior, K. Leung | Informational | October 2007 |
| 4679 | DSL Forum Vendor-Specific RADIUS AttributesV. Mammoliti, G. Zorn, P. Arberg, R. Rennison | Informational | September 2006 |
| 4671 | RADIUS Accounting Server MIB for IPv6D. Nelson | Informational | August 2006 |
| 4670 | RADIUS Accounting Client MIB for IPv6D. Nelson | Informational | August 2006 |
| 4441 | The IEEE 802/IETF RelationshipB. Aboba, Ed. · obsoleted by RFC 7241 | Informational | March 2006 |
| 4372 | Chargeable User IdentityF. Adrangi, A. Lior, J. Korhonen, J. Loughney | Proposed Standard | January 2006 |
| 4282 | The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542 | Proposed Standard | December 2005 |
| 4006 | Diameter Credit-Control ApplicationH. Hakala, L. Mattila, J-P. Koskinen, M. Stura, J. Loughney · obsoleted by RFC 8506 | Proposed Standard | August 2005 |
| 4005 | Diameter Network Access Server ApplicationP. Calhoun, G. Zorn, D. Spence, D. Mitton · obsoleted by RFC 7155 | Proposed Standard | August 2005 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 3580 | IEEE 802.1X Remote Authentication Dial In User Service (RADIUS) Usage GuidelinesP. Congdon, B. Aboba, A. Smith, G. Zorn, J. Roese | Informational | September 2003 |
| 3579 | RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)B. Aboba, P. Calhoun | Informational | September 2003 |
| 3576 | Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)M. Chiba, G. Dommety, M. Eklund, D. Mitton, B. Aboba · obsoleted by RFC 5176 | Informational | July 2003 |
| 3575 | IANA Considerations for RADIUS (Remote Authentication Dial In User Service)B. Aboba | Proposed Standard | July 2003 |
| 3539 | Authentication, Authorization and Accounting (AAA) Transport ProfileB. Aboba, J. Wood | Proposed Standard | June 2003 |
| 3162 | RADIUS and IPv6B. Aboba, G. Zorn, D. Mitton | Proposed Standard | August 2001 |
| 2989 | Criteria for Evaluating AAA Protocols for Network AccessB. Aboba, P. Calhoun, S. Glass, T. Hiller, P. McCann, H. Shiino, P. Walsh, G. Zorn, G. Dommety, C. Perkins, B. Patil, D. Mitton, S. Manning, M. Beadles, X. Chen, S. Sivalingham, A. Hameed, M. Munson, S. Jacobs, B. Lim, B. Hirschman, R. Hsu, H. Koo, M. Lipford, E. Campbell, Y. Xu, S. Baba, E. Jaques | Informational | November 2000 |
| 2924 | Accounting Attributes and Record FormatsN. Brownlee, A. Blount | Informational | September 2000 |
| 2899 | Request for Comments Summary RFC Numbers 2800-2899S. Ginoza | Informational | May 2001 |
| 2882 | Network Access Servers Requirements: Extended RADIUS PracticesD. Mitton | Informational | July 2000 |
| 2881 | Network Access Server Requirements Next Generation (NASREQNG) NAS ModelD. Mitton, M. Beadles | Informational | July 2000 |
| 2869 | RADIUS ExtensionsC. Rigney, W. Willats, P. Calhoun | Informational | June 2000 |
| 2867 | RADIUS Accounting Modifications for Tunnel Protocol SupportG. Zorn, B. Aboba, D. Mitton | Informational | June 2000 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |