| 9960 | Segment Routing Point-to-Multipoint PolicyR. Parekh, Ed., D. Voyer, Ed., C. Filsfils, H. Bidgoli, Z. Zhang | Proposed Standard | April 2026 |
| 9926 | Prefix Registration for IPv6 Neighbor DiscoveryP. Thubert, Ed. | Proposed Standard | February 2026 |
| 9665 | Service Registration Protocol for DNS-Based Service DiscoveryT. Lemon, S. Cheshire | Proposed Standard | June 2025 |
| 9524 | Segment Routing Replication for Multipoint Service DeliveryD. Voyer, Ed., C. Filsfils, R. Parekh, H. Bidgoli, Z. Zhang | Proposed Standard | February 2024 |
| 9484 | Proxying IP in HTTPT. Pauly, Ed., D. Schinazi, A. Chernyakhovsky, M. Kühlewind, M. Westerlund | Proposed Standard | October 2023 |
| 9252 | BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)G. Dawra, Ed., K. Talaulikar, Ed., R. Raszuk, B. Decraene, S. Zhuang, J. Rabadan | Proposed Standard | July 2022 |
| 9099 | Operational Security Considerations for IPv6 NetworksÉ. Vyncke, K. Chittimaneni, M. Kaeo, E. Rey | Informational | August 2021 |
| 9008 | Using RPI Option Type, Routing Header for Source Routes, and IPv6-in-IPv6 Encapsulation in the RPL Data PlaneM.I. Robles, M. Richardson, P. Thubert | Proposed Standard | April 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 8987 | DHCPv6 Prefix Delegating Relay RequirementsI. Farrer, N. Kottapalli, M. Hunek, R. Patterson | Proposed Standard | February 2021 |
| 8963 | Evaluation of a Sample of RFCs Produced in 2018C. Huitema | Informational | January 2021 |
| 8803 | 0-RTT TCP Convert ProtocolO. Bonaventure, Ed., M. Boucadair, Ed., S. Gundavelli, S. Seo, B. Hesmans | Experimental | July 2020 |
| 8754 | IPv6 Segment Routing Header (SRH)C. Filsfils, Ed., D. Dukes, Ed., S. Previdi, J. Leddy, S. Matsushima, D. Voyer | Proposed Standard | March 2020 |
| 8704 | Enhanced Feasible-Path Unicast Reverse Path ForwardingK. Sriram, D. Montgomery, J. Haas | Best Current Practice | February 2020 |
| 8678 | Enterprise Multihoming using Provider-Assigned IPv6 Addresses without Network Prefix Translation: Requirements and SolutionsF. Baker, C. Bowers, J. Linkova | Informational | December 2019 |
| 8633 | Network Time Protocol Best Current PracticesD. Reilly, H. Stenn, D. Sibold | Best Current Practice | July 2019 |
| 8539 | Softwire Provisioning Using DHCPv4 over DHCPv6I. Farrer, Q. Sun, Y. Cui, L. Sun | Proposed Standard | March 2019 |
| 8517 | An Inventory of Transport-Centric Functions Provided by Middleboxes: An Operator PerspectiveD. Dolson, Ed., J. Snellman, M. Boucadair, Ed., C. Jacquenet | Informational | February 2019 |
| 8475 | Using Conditional Router Advertisements for Enterprise MultihomingJ. Linkova, M. Stucchi | Informational | October 2018 |
| 8404 | Effects of Pervasive Encryption on OperatorsK. Moriarty, Ed., A. Morton, Ed. | Informational | July 2018 |
| 8313 | Use of Multicast across Inter-domain Peering PointsP. Tarapore, Ed., R. Sayko, G. Shepherd, T. Eckert, Ed., R. Krishnan | Best Current Practice | January 2018 |
| 8073 | Coordinating Attack Response at Internet Scale (CARIS) Workshop ReportK. Moriarty, M. Ford | Informational | March 2017 |
| 8043 | Source-Address-Dependent Routing and Source Address Selection for IPv6 Hosts: Overview of the Problem SpaceB. Sarikaya, M. Boucadair | Informational | January 2017 |
| 8028 | First-Hop Router Selection by Hosts in a Multi-Prefix NetworkF. Baker, B. Carpenter | Proposed Standard | November 2016 |
| 8021 | Generation of IPv6 Atomic Fragments Considered HarmfulF. Gont, W. Liu, T. Anderson | Informational | January 2017 |
| 8004 | Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. Eggert | Proposed Standard | October 2016 |
| 7881 | Seamless Bidirectional Forwarding Detection (S-BFD) for IPv4, IPv6, and MPLSC. Pignataro, D. Ward, N. Akiya | Proposed Standard | July 2016 |
| 7877 | Session Peering Provisioning Framework (SPPF)K. Cartwright, V. Bhatia, S. Ali, D. Schwartz | Proposed Standard | August 2016 |
| 7756 | Stateless IP/ICMP Translation for IPv6 Internet Data Center Environments (SIIT-DC): Dual Translation ModeT. Anderson, S. Steffann | Proposed Standard | February 2016 |
| 7754 | Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. Nordmark | Informational | March 2016 |
| 7599 | Mapping of Address and Port using Translation (MAP-T)X. Li, C. Bao, W. Dec, Ed., O. Troan, S. Matsushima, T. Murakami | Proposed Standard | July 2015 |
| 7597 | Mapping of Address and Port with Encapsulation (MAP-E)O. Troan, Ed., W. Dec, X. Li, C. Bao, S. Matsushima, T. Murakami, T. Taylor, Ed. | Proposed Standard | July 2015 |
| 7596 | Lightweight 4over6: An Extension to the Dual-Stack Lite ArchitectureY. Cui, Q. Sun, M. Boucadair, T. Tsou, Y. Lee, I. Farrer | Proposed Standard | July 2015 |
| 7526 | Deprecating the Anycast Prefix for 6to4 Relay RoutersO. Troan, B. Carpenter, Ed. | Best Current Practice | May 2015 |
| 7513 | Source Address Validation Improvement (SAVI) Solution for DHCPJ. Bi, J. Wu, G. Yao, F. Baker | Proposed Standard | May 2015 |
| 7454 | BGP Operations and SecurityJ. Durand, I. Pepelnjak, G. Doering | Best Current Practice | February 2015 |
| 7430 | Analysis of Residual Threats and Possible Fixes for Multipath TCP (MPTCP)M. Bagnulo, C. Paasch, F. Gont, O. Bonaventure, C. Raiciu | Informational | July 2015 |
| 7381 | Enterprise IPv6 Deployment GuidelinesK. Chittimaneni, T. Chown, L. Howard, V. Kuarsingh, Y. Pouffary, E. Vyncke | Informational | October 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7339 | Session Initiation Protocol (SIP) Overload ControlV. Gurbani, Ed., V. Hilt, H. Schulzrinne | Proposed Standard | September 2014 |
| 7219 | SEcure Neighbor Discovery (SEND) Source Address Validation Improvement (SAVI)M. Bagnulo, A. Garcia-Martinez | Proposed Standard | May 2014 |
| 7112 | Implications of Oversized IPv6 Header ChainsF. Gont, V. Manral, R. Bonica | Proposed Standard | January 2014 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7059 | A Comparison of IPv6-over-IPv4 Tunnel MechanismsS. Steffann, I. van Beijnum, R. van Rein | Informational | November 2013 |
| 7039 | Source Address Validation Improvement (SAVI) FrameworkJ. Wu, J. Bi, M. Bagnulo, F. Baker, C. Vogt, Ed. | Informational | October 2013 |
| 7010 | IPv6 Site Renumbering Gap AnalysisB. Liu, S. Jiang, B. Carpenter, S. Venaas, W. George | Informational | September 2013 |
| 6959 | Source Address Validation Improvement (SAVI) Threat ScopeD. McPherson, F. Baker, J. Halpern | Informational | May 2013 |
| 6936 | Applicability Statement for the Use of IPv6 UDP Datagrams with Zero ChecksumsG. Fairhurst, M. Westerlund | Proposed Standard | April 2013 |
| 6935 | IPv6 and UDP Checksums for Tunneled PacketsM. Eubanks, P. Chimento, M. Westerlund | Proposed Standard | April 2013 |
| 6888 | Common Requirements for Carrier-Grade NATs (CGNs)S. Perreault, Ed., I. Yamagata, S. Miyakawa, A. Nakagawa, H. Ashida | Best Current Practice | April 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6752 | Issues with Private IP Addressing in the InternetA. Kirkham | Informational | September 2012 |
| 6751 | Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)R. Despres, Ed., B. Carpenter, D. Wing, S. Jiang | Experimental | October 2012 |
| 6746 | IPv4 Options for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6745 | ICMP Locator Update Message for the Identifier-Locator Network Protocol for IPv4 (ILNPv4)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6743 | ICMP Locator Update Message for the Identifier-Locator Network Protocol for IPv6 (ILNPv6)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6740 | Identifier-Locator Network Protocol (ILNP) Architectural DescriptionRJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6629 | Considerations on the Application of the Level 3 Multihoming Shim Protocol for IPv6 (Shim6)J. Abley, M. Bagnulo, A. Garcia-Martinez | Informational | June 2012 |
| 6620 | FCFS SAVI: First-Come, First-Served Source Address Validation Improvement for Locally Assigned IPv6 AddressesE. Nordmark, M. Bagnulo, E. Levy-Abegnoli | Proposed Standard | May 2012 |
| 6556 | Testing Eyeball HappinessF. Baker | Informational | April 2012 |
| 6437 | IPv6 Flow Label SpecificationS. Amante, B. Carpenter, S. Jiang, J. Rajahalme | Proposed Standard | November 2011 |
| 6418 | Multiple Interfaces and Provisioning Domains Problem StatementM. Blanchet, P. Seite | Informational | November 2011 |
| 6404 | Session PEERing for Multimedia INTerconnect (SPEERMINT) Security Threats and Suggested CountermeasuresJ. Seedorf, S. Niccolini, E. Chen, H. Scholz | Informational | November 2011 |
| 6346 | The Address plus Port (A+P) Approach to the IPv4 Address ShortageR. Bush, Ed. | Experimental | August 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6285 | Unicast-Based Rapid Acquisition of Multicast RTP SessionsB. Ver Steeg, A. Begen, T. Van Caenegem, Z. Vax | Proposed Standard | June 2011 |
| 6284 | Port Mapping between Unicast and Multicast RTP SessionsA. Begen, D. Wing, T. Van Caenegem | Proposed Standard | June 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6274 | Security Assessment of the Internet Protocol Version 4F. Gont | Informational | July 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6204 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark, O. Troan, Ed. · obsoleted by RFC 7084 | Informational | April 2011 |
| 6192 | Protecting the Router Control PlaneD. Dugal, C. Pignataro, R. Dunn | Informational | March 2011 |
| 6106 | IPv6 Router Advertisement Options for DNS ConfigurationJ. Jeong, S. Park, L. Beloeil, S. Madanapalli · obsoleted by RFC 8106 | Proposed Standard | November 2010 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6045 | Real-time Inter-network Defense (RID)K. Moriarty · obsoleted by RFC 6545 | Informational | November 2010 |
| 6018 | IPv4 and IPv6 GreynetsF. Baker, W. Harrop, G. Armitage | Informational | September 2010 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 5944 | IP Mobility Support for IPv4, RevisedC. Perkins, Ed. | Proposed Standard | November 2010 |
| 5881 | Bidirectional Forwarding Detection (BFD) for IPv4 and IPv6 (Single Hop)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5452 | Measures for Making DNS More Resilient against Forged AnswersA. Hubert, R. van Mook | Proposed Standard | January 2009 |
| 5409 | Using the Boneh-Franklin and Boneh-Boyen Identity-Based Encryption Algorithms with the Cryptographic Message Syntax (CMS)L. Martin, M. Schertler | Informational | January 2009 |
| 5408 | Identity-Based Encryption Architecture and Supporting Data StructuresG. Appenzeller, L. Martin, M. Schertler | Informational | January 2009 |
| 5358 | Preventing Use of Recursive Nameservers in Reflector AttacksJ. Damas, F. Neves | Best Current Practice | October 2008 |
| 5210 | A Source Address Validation Architecture (SAVA) Testbed and Deployment ExperienceJ. Wu, J. Bi, X. Li, G. Ren, K. Xu, M. Williams | Experimental | June 2008 |
| 5204 | Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. Eggert · obsoleted by RFC 8004 | Experimental | April 2008 |
| 5095 | Deprecation of Type 0 Routing Headers in IPv6J. Abley, P. Savola, G. Neville-Neil | Proposed Standard | December 2007 |
| 5006 | IPv6 Router Advertisement Option for DNS ConfigurationJ. Jeong, Ed., S. Park, L. Beloeil, S. Madanapalli · obsoleted by RFC 6106 | Experimental | September 2007 |
| 4993 | A Lightweight UDP Transfer Protocol for the Internet Registry Information ServiceA. Newton | Proposed Standard | August 2007 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 4980 | Analysis of Multihoming in Network Mobility SupportC. Ng, T. Ernst, E. Paik, M. Bagnulo | Informational | October 2007 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4948 | Report from the IAB workshop on Unwanted Traffic March 9-10, 2006L. Andersson, E. Davies, L. Zhang | Informational | August 2007 |
| 4832 | Security Threats to Network-Based Localized Mobility Management (NETLMM)C. Vogt, J. Kempf | Informational | April 2007 |
| 4786 | Operation of Anycast ServicesJ. Abley, K. Lindqvist | Best Current Practice | December 2006 |
| 4778 | Operational Security Current Practices in Internet Service Provider EnvironmentsM. Kaeo | Informational | January 2007 |
| 4732 | Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IAB | Informational | December 2006 |
| 4651 | A Taxonomy and Analysis of Enhancements to Mobile IPv6 Route OptimizationC. Vogt, J. Arkko | Informational | February 2007 |
| 4609 | Protocol Independent Multicast - Sparse Mode (PIM-SM) Multicast Routing Security Issues and EnhancementsP. Savola, R. Lehtonen, D. Meyer | Informational | October 2006 |
| 4570 | Session Description Protocol (SDP) Source FiltersB. Quinn, R. Finlayson | Proposed Standard | July 2006 |
| 4218 | Threats Relating to IPv6 Multihoming SolutionsE. Nordmark, T. Li | Informational | October 2005 |
| 4213 | Basic Transition Mechanisms for IPv6 Hosts and RoutersE. Nordmark, R. Gilligan | Proposed Standard | October 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4174 | The IPv4 Dynamic Host Configuration Protocol (DHCP) Option for the Internet Storage Name ServiceC. Monia, J. Tseng, K. Gibbons | Proposed Standard | September 2005 |
| 4140 | Hierarchical Mobile IPv6 Mobility Management (HMIPv6)H. Soliman, C. Castelluccia, K. El Malki, L. Bellier · obsoleted by RFC 5380 | Experimental | August 2005 |
| 3964 | Security Considerations for 6to4P. Savola, C. Patel | Informational | December 2004 |
| 3871 | Operational Security Requirements for Large Internet Service Provider (ISP) IP Network InfrastructureG. Jones, Ed. | Informational | September 2004 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3697 | IPv6 Flow Label SpecificationJ. Rajahalme, A. Conta, B. Carpenter, S. Deering · obsoleted by RFC 6437 | Proposed Standard | March 2004 |
| 3489 | STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)J. Rosenberg, J. Weinberger, C. Huitema, R. Mahy · obsoleted by RFC 5389 | Proposed Standard | March 2003 |
| 3344 | IP Mobility Support for IPv4C. Perkins, Ed. · obsoleted by RFC 5944 | Proposed Standard | August 2002 |
| 3220 | IP Mobility Support for IPv4C. Perkins, Ed. · obsoleted by RFC 3344 | Proposed Standard | January 2002 |
| 3013 | Recommended Internet Service Provider Security Services and ProceduresT. Killalea | Best Current Practice | November 2000 |