{
  "number": 2817,
  "title": "Upgrading to TLS Within HTTP/1.1",
  "authors": [
    "R. Khare",
    "S. Lawrence"
  ],
  "published": "2000-05",
  "status": "Proposed Standard",
  "stream": "IETF",
  "area": "sec",
  "working_group": "tls",
  "pages": 13,
  "formats": [
    "TXT",
    "HTML"
  ],
  "abstract": "This memo explains how to use the Upgrade mechanism in HTTP/1.1 to initiate Transport Layer Security (TLS) over an existing TCP connection. [STANDARDS-TRACK]",
  "keywords": [
    "HTTP",
    "hypertext transfer protocol",
    "TLS",
    "transport layer security"
  ],
  "draft": "draft-ietf-tls-http-upgrade-05",
  "doi": "10.17487/RFC2817",
  "errata_url": "https://www.rfc-editor.org/errata/rfc2817",
  "updates": [
    "RFC2616"
  ],
  "updated_by": [
    "RFC7230",
    "RFC7231"
  ],
  "urls": {
    "html": "https://rfc.dk/rfc2817/",
    "text": "https://rfc.dk/rfc2817.txt",
    "rfc_editor": "https://www.rfc-editor.org/rfc/rfc2817",
    "datatracker": "https://datatracker.ietf.org/doc/rfc2817/"
  },
  "text_modified": "2000-05-05T21:35:16Z"
}
