| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9790 | IANA Registry and Processing Recommendations for the First Nibble Following a Label StackK. Kompella, S. Bryant, M. Bocci, G. Mirsky, Ed., L. Andersson, J. Dong | Proposed Standard | July 2025 |
| 8250 | IPv6 Performance and Diagnostic Metrics (PDM) Destination OptionN. Elkins, R. Hamilton, M. Ackermann | Proposed Standard | September 2017 |
| 7731 | Multicast Protocol for Low-Power and Lossy Networks (MPL)J. Hui, R. Kelsey | Proposed Standard | February 2016 |
| 7680 | A One-Way Loss Metric for IP Performance Metrics (IPPM)G. Almes, S. Kalidindi, M. Zekauskas, A. Morton, Ed. | Internet Standard | January 2016 |
| 7679 | A One-Way Delay Metric for IP Performance Metrics (IPPM)G. Almes, S. Kalidindi, M. Zekauskas, A. Morton, Ed. | Internet Standard | January 2016 |
| 7605 | Recommendations on Using Assigned Transport Port NumbersJ. Touch | Best Current Practice | August 2015 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |
| 7279 | An Acceptable Use Policy for New ICMP Types and CodesM. Shore, C. Pignataro | Best Current Practice | May 2014 |
| 7045 | Transmission and Processing of IPv6 Extension HeadersB. Carpenter, S. Jiang | Proposed Standard | December 2013 |
| 6994 | Shared Use of Experimental TCP OptionsJ. Touch | Proposed Standard | August 2013 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 6746 | IPv4 Options for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6744 | IPv6 Nonce Destination Option for the Identifier-Locator Network Protocol for IPv6 (ILNPv6)RJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6621 | Simplified Multicast ForwardingJ. Macker, Ed. | Experimental | May 2012 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6117 | IANA Registration of Enumservices: Guide, Template, and IANA ConsiderationsB. Hoeneisen, A. Mayrhofer, J. Livingood | Proposed Standard | March 2011 |
| 6021 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 6991 | Proposed Standard | October 2010 |
| 5777 | Traffic Classification and Quality of Service (QoS) Attributes for DiameterJ. Korhonen, H. Tschofenig, M. Arumaithurai, M. Jones, Ed., A. Lior | Proposed Standard | February 2010 |
| 5771 | IANA Guidelines for IPv4 Multicast Address AssignmentsM. Cotton, L. Vegoda, D. Meyer | Best Current Practice | March 2010 |
| 5595 | The Datagram Congestion Control Protocol (DCCP) Service CodesG. Fairhurst | Proposed Standard | September 2009 |
| 5237 | IANA Allocation Guidelines for the Protocol FieldJ. Arkko, S. Bradner | Best Current Practice | February 2008 |
| 4727 | Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP HeadersB. Fenner | Proposed Standard | November 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4413 | TCP/IP Field BehaviorM. West, S. McCann | Informational | March 2006 |
| 3692 | Assigning Experimental and Testing Numbers Considered UsefulT. Narten | Best Current Practice | January 2004 |
| 3540 | Robust Explicit Congestion Notification (ECN) Signaling with NoncesN. Spring, D. Wetherall, D. Ely | Historic | June 2003 |
| 3289 | Management Information Base for the Differentiated Services ArchitectureF. Baker, K. Chan, A. Smith | Proposed Standard | June 2002 |
| 3260 | New Terminology and Clarifications for DiffservD. Grossman | Informational | April 2002 |
| 3228 | IANA Considerations for IPv4 Internet Group Management Protocol (IGMP)B. Fenner · obsoleted by RFC 9778 | Best Current Practice | February 2002 |
| 3175 | Aggregation of RSVP for IPv4 and IPv6 ReservationsF. Baker, C. Iturralde, F. Le Faucheur, B. Davie | Proposed Standard | September 2001 |
| 3171 | IANA Guidelines for IPv4 Multicast Address AssignmentsZ. Albanna, K. Almeroth, D. Meyer, M. Schipper · obsoleted by RFC 5771 | Best Current Practice | August 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3138 | Extended Assignments in 233/8D. Meyer · obsoleted by RFC 5771 | Informational | June 2001 |
| 3077 | A Link-Layer Tunneling Mechanism for Unidirectional LinksE. Duros, W. Dabbous, H. Izumiyama, N. Fujii, Y. Zhang | Proposed Standard | March 2001 |