| 10069 | Managing Multiple Paths for a QUIC ConnectionY. Liu, Ed., Y. Ma, Q. De Coninck, Ed., O. Bonaventure, C. Huitema, M. Kühlewind, Ed. | Proposed Standard | November 2026 |
| 10065 | A YANG Data Model and RADIUS Extension for Policy-Based Network Access ControlQ. Ma, Ed., Q. Wu, M. Boucadair, Ed., D. King | Proposed Standard | October 2026 |
| 9956 | A Non-Queue-Building Per-Hop Behavior (NQB PHB) for Differentiated ServicesG. White, T. Fossati, R. Geib | Proposed Standard | May 2026 |
| 9894 | Dynamic Link Exchange Protocol (DLEP) Diffserv Aware Credit Window ExtensionB. Cheng, D. Wiggins, L. Berger, D. Eastlake 3rd, Ed. | Proposed Standard | January 2026 |
| 9893 | Dynamic Link Exchange Protocol (DLEP) Credit-Based Flow Control Messages and Data ItemsB. Cheng, D. Wiggins, S. Ratliff, L. Berger, E. Kinzie, Ed. | Proposed Standard | January 2026 |
| 9892 | Dynamic Link Exchange Protocol (DLEP) Traffic Classification Data ItemB. Cheng, D. Wiggins, L. Berger, D. Fedyk, Ed. | Proposed Standard | January 2026 |
| 9889 | A Realization of Network Slices for 5G Networks Using Current IP/MPLS TechnologiesK. Szarkowicz, Ed., R. Roberts, Ed., J. Lucek, M. Boucadair, Ed., LM. Contreras | Informational | November 2025 |
| 9801 | Private Line Emulation over Packet Switched NetworksS. Gringeri, J. Whittaker, N. Leymann, C. Schmutzer, Ed., C. Brown | Proposed Standard | July 2025 |
| 9732 | A Framework for NRP-Based Enhanced Virtual Private NetworksJ. Dong, S. Bryant, Z. Li, T. Miyasaka, Y. Lee | Informational | March 2025 |
| 9699 | Use Case for an Extended Reality Application on Edge Computing InfrastructureR. Krishna, A. Rahman | Informational | December 2024 |
| 9522 | Overview and Principles of Internet Traffic EngineeringA. Farrel, Ed. | Informational | January 2024 |
| 9466 | PIM Assert Message PackingY. Liu, Ed., T. Eckert, Ed., M. McBride, Z. Zhang | Proposed Standard | October 2023 |
| 9450 | Reliable and Available Wireless (RAW) Use CasesCJ. Bernardos, Ed., G. Papadopoulos, P. Thubert, F. Theoleyre | Informational | August 2023 |
| 9435 | Considerations for Assigning a New Recommended Differentiated Services Code Point (DSCP)A. Custura, G. Fairhurst, R. Secchi | Informational | July 2023 |
| 9330 | Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: ArchitectureB. Briscoe, Ed., K. De Schepper, M. Bagnulo, G. White | Informational | January 2023 |
| 9320 | Deterministic Networking (DetNet) Bounded LatencyN. Finn, J.-Y. Le Boudec, E. Mohammadpour, J. Zhang, B. Varga | Informational | November 2022 |
| 9312 | Manageability of the QUIC Transport ProtocolM. Kühlewind, B. Trammell | Informational | September 2022 |
| 9308 | Applicability of the QUIC Transport ProtocolM. Kühlewind, B. Trammell | Informational | September 2022 |
| 9065 | Considerations around Transport Header Confidentiality, Network Operations, and the Evolution of Internet Transport ProtocolsG. Fairhurst, C. Perkins | Informational | July 2021 |
| 9055 | Deterministic Networking (DetNet) Security ConsiderationsE. Grossman, Ed., T. Mizrahi, A. Hacker | Informational | June 2021 |
| 9049 | Path Aware Networking: Obstacles to Deployment (A Bestiary of Roads Not Taken)S. Dawkins, Ed. | Informational | June 2021 |
| 9028 | Native NAT Traversal Mode for the Host Identity ProtocolA. Keränen, J. Melén, M. Komu, Ed. | Experimental | July 2021 |
| 8939 | Deterministic Networking (DetNet) Data Plane: IPB. Varga, Ed., J. Farkas, L. Berger, D. Fedyk, S. Bryant | Proposed Standard | November 2020 |
| 8655 | Deterministic Networking ArchitectureN. Finn, P. Thubert, B. Varga, J. Farkas | Proposed Standard | October 2019 |
| 8651 | Dynamic Link Exchange Protocol (DLEP) Control-Plane-Based Pause ExtensionB. Cheng, D. Wiggins, L. Berger, Ed. | Proposed Standard | October 2019 |
| 8622 | A Lower-Effort Per-Hop Behavior (LE PHB) for Differentiated ServicesR. Bless | Proposed Standard | June 2019 |
| 8445 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. Rosenberg | Proposed Standard | July 2018 |
| 8436 | Update to IANA Registration Procedures for Pool 3 Values in the Differentiated Services Field Codepoints (DSCP) RegistryG. Fairhurst | Proposed Standard | August 2018 |
| 8325 | Mapping Diffserv to IEEE 802.11T. Szigeti, J. Henry, F. Baker | Proposed Standard | February 2018 |
| 8304 | Transport Features of the User Datagram Protocol (UDP) and Lightweight UDP (UDP-Lite)G. Fairhurst, T. Jones | Informational | February 2018 |
| 8303 | On the Usage of Transport Features Provided by IETF Transport ProtocolsM. Welzl, M. Tuexen, N. Khademi | Informational | February 2018 |
| 8100 | Diffserv-Interconnection Classes and PracticeR. Geib, Ed., D. Black | Informational | March 2017 |
| 8088 | How to Write an RTP Payload FormatM. Westerlund | Informational | May 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7806 | On Queuing, Marking, and DroppingF. Baker, R. Pan | Informational | April 2016 |
| 7657 | Differentiated Services (Diffserv) and Real-Time CommunicationD. Black, Ed., P. Jones | Informational | November 2015 |
| 7567 | IETF Recommendations Regarding Active Queue ManagementF. Baker, Ed., G. Fairhurst, Ed. | Best Current Practice | July 2015 |
| 7417 | Extensions to Generic Aggregate RSVP for IPv4 and IPv6 Reservations over Pre-Congestion Notification (PCN) DomainsG. Karagiannis, A. Bhargava | Experimental | December 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7325 | MPLS Forwarding Compliance and Performance RequirementsC. Villamizar, Ed., K. Kompella, S. Amante, A. Malis, C. Pignataro | Informational | August 2014 |
| 7297 | IP Connectivity Provisioning Profile (CPP)M. Boucadair, C. Jacquenet, N. Wang | Informational | July 2014 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7295 | Report from the IAB/IRTF Workshop on Congestion Control for Interactive Real-Time CommunicationH. Tschofenig, L. Eggert, Z. Sarker | Informational | July 2014 |
| 7226 | Requirements for Advanced Multipath in MPLS NetworksC. Villamizar, Ed., D. McDysan, Ed., S. Ning, A. Malis, L. Yong | Informational | May 2014 |
| 7222 | Quality-of-Service Option for Proxy Mobile IPv6M. Liebsch, P. Seite, H. Yokota, J. Korhonen, S. Gundavelli | Proposed Standard | May 2014 |
| 7190 | Use of Multipath with MPLS and MPLS Transport Profile (MPLS-TP)C. Villamizar | Informational | March 2014 |
| 6908 | Deployment Considerations for Dual-Stack LiteY. Lee, R. Maglione, C. Williams, C. Jacquenet, M. Boucadair | Informational | March 2013 |
| 6789 | Congestion Exposure (ConEx) Concepts and Use CasesB. Briscoe, Ed., R. Woundy, Ed., A. Cooper, Ed. | Informational | December 2012 |
| 6662 | Pre-Congestion Notification (PCN) Boundary-Node Behavior for the Single Marking (SM) Mode of OperationA. Charny, J. Zhang, G. Karagiannis, M. Menth, T. Taylor, Ed. | Experimental | July 2012 |
| 6661 | Pre-Congestion Notification (PCN) Boundary-Node Behavior for the Controlled Load (CL) Mode of OperationA. Charny, F. Huang, G. Karagiannis, M. Menth, T. Taylor, Ed. | Experimental | July 2012 |
| 6371 | Operations, Administration, and Maintenance Framework for MPLS-Based Transport NetworksI. Busi, Ed., D. Allan, Ed. | Informational | September 2011 |
| 6274 | Security Assessment of the Internet Protocol Version 4F. Gont | Informational | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6108 | Comcast's Web Notification System DesignC. Chung, A. Kasyanov, J. Livingood, N. Mody, B. Van Lieu | Historic | February 2011 |
| 6077 | Open Research Issues in Internet Congestion ControlD. Papadimitriou, Ed., M. Welzl, M. Scharf, B. Briscoe | Informational | February 2011 |
| 6057 | Comcast's Protocol-Agnostic Congestion Management SystemC. Bastian, T. Klieber, J. Livingood, J. Mills, R. Woundy | Historic | December 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5977 | RMD-QOSM: The NSIS Quality-of-Service Model for Resource Management in DiffservA. Bader, L. Westberg, G. Karagiannis, C. Kappler, T. Phelan | Experimental | October 2010 |
| 5976 | Y.1541-QOSM: Model for Networks Using Y.1541 Quality-of-Service ClassesG. Ash, A. Morton, M. Dolly, P. Tarapore, C. Dvorak, Y. El Mghazli | Experimental | October 2010 |
| 5975 | QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)G. Ash, Ed., A. Bader, Ed., C. Kappler, Ed., D. Oran, Ed. | Experimental | October 2010 |
| 5945 | Resource Reservation Protocol (RSVP) Proxy ApproachesF. Le Faucheur, J. Manner, D. Wing, A. Guillou | Informational | October 2010 |
| 5865 | A Differentiated Services Code Point (DSCP) for Capacity-Admitted TrafficF. Baker, J. Polk, M. Dolly | Proposed Standard | May 2010 |
| 5783 | Congestion Control in the RFC SeriesM. Welzl, W. Eddy | Informational | February 2010 |
| 5777 | Traffic Classification and Quality of Service (QoS) Attributes for DiameterJ. Korhonen, H. Tschofenig, M. Arumaithurai, M. Jones, Ed., A. Lior | Proposed Standard | February 2010 |
| 5715 | A Framework for Loop-Free ConvergenceM. Shand, S. Bryant | Informational | January 2010 |
| 5670 | Metering and Marking Behaviour of PCN-NodesP. Eardley, Ed. | Proposed Standard | November 2009 |
| 5624 | Quality of Service Parameters for Usage with DiameterJ. Korhonen, Ed., H. Tschofenig, E. Davies | Proposed Standard | August 2009 |
| 5594 | Report from the IETF Workshop on Peer-to-Peer (P2P) Infrastructure, May 28, 2008J. Peterson, A. Cooper | Informational | July 2009 |
| 5559 | Pre-Congestion Notification (PCN) ArchitectureP. Eardley, Ed. | Informational | June 2009 |
| 5501 | Requirements for Multicast Support in Virtual Private LAN ServicesY. Kamite, Ed., Y. Wada, Y. Serbest, T. Morin, L. Fang | Informational | March 2009 |
| 5405 | Unicast UDP Usage Guidelines for Application DesignersL. Eggert, G. Fairhurst · obsoleted by RFC 8085 | Best Current Practice | November 2008 |
| 5290 | Comments on the Usefulness of Simple Best-Effort TrafficS. Floyd, M. Allman | Informational | July 2008 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |
| 5160 | Considerations of Provider-to-Provider Agreements for Internet-Scale Quality of Service (QoS)P. Levis, M. Boucadair | Informational | March 2008 |
| 5087 | Time Division Multiplexing over IP (TDMoIP)Y(J). Stein, R. Shashoua, R. Insler, M. Anavi | Informational | December 2007 |
| 5086 | Structure-Aware Time Division Multiplexed (TDM) Circuit Emulation Service over Packet Switched Network (CESoPSN)A. Vainshtein, Ed., I. Sasson, E. Metz, T. Frost, P. Pate | Informational | December 2007 |
| 4923 | Quality of Service (QoS) Signaling in a Nested Virtual Private NetworkF. Baker, P. Bose | Informational | August 2007 |
| 4842 | Synchronous Optical Network/Synchronous Digital Hierarchy (SONET/SDH) Circuit Emulation over Packet (CEP)A. Malis, P. Pate, R. Cohen, Ed., D. Zelig | Proposed Standard | April 2007 |
| 4834 | Requirements for Multicast in Layer 3 Provider-Provisioned Virtual Private Networks (PPVPNs)T. Morin, Ed. | Informational | April 2007 |
| 4804 | Aggregation of Resource ReSerVation Protocol (RSVP) Reservations over MPLS TE/DS-TE TunnelsF. Le Faucheur, Ed. | Proposed Standard | February 2007 |
| 4710 | Real-time Application Quality-of-Service Monitoring (RAQMON) FrameworkA. Siddiqui, D. Romascanu, E. Golovinsky | Proposed Standard | October 2006 |
| 4594 | Configuration Guidelines for DiffServ Service ClassesJ. Babiarz, K. Chan, F. Baker | Informational | August 2006 |
| 4553 | Structure-Agnostic Time Division Multiplexing (TDM) over Packet (SAToP)A. Vainshtein, Ed., YJ. Stein, Ed. | Proposed Standard | June 2006 |
| 4542 | Implementing an Emergency Telecommunications Service (ETS) for Real-Time Services in the Internet Protocol SuiteF. Baker, J. Polk | Informational | May 2006 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4216 | MPLS Inter-Autonomous System (AS) Traffic Engineering (TE) RequirementsR. Zhang, Ed., J.-P. Vasseur, Ed. | Informational | November 2005 |
| 4190 | Framework for Supporting Emergency Telecommunications Service (ETS) in IP TelephonyK. Carlberg, I. Brown, C. Beard | Informational | November 2005 |
| 4172 | iFCP - A Protocol for Internet Fibre Channel Storage NetworkingC. Monia, R. Mullendore, F. Travostino, W. Jeong, M. Edwards | Proposed Standard | September 2005 |
| 4128 | Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance EvaluationW. Lai | Informational | June 2005 |
| 4124 | Protocol Extensions for Support of Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, Ed. | Proposed Standard | June 2005 |
| 4115 | A Differentiated Service Two-Rate, Three-Color Marker with Efficient Handling of in-Profile TrafficO. Aboul-Magd, S. Rabie | Informational | July 2005 |
| 4110 | A Framework for Layer 3 Provider-Provisioned Virtual Private Networks (PPVPNs)R. Callon, M. Suzuki | Informational | July 2005 |
| 4105 | Requirements for Inter-Area MPLS Traffic EngineeringJ.-L. Le Roux, Ed., J.-P. Vasseur, Ed., J. Boyle, Ed. | Informational | June 2005 |
| 4031 | Service Requirements for Layer 3 Provider Provisioned Virtual Private Networks (PPVPNs)M. Carugi, Ed., D. McDysan, Ed. | Informational | April 2005 |
| 4023 | Encapsulating MPLS in IP or Generic Routing Encapsulation (GRE)T. Worster, Y. Rekhter, E. Rosen, Ed. | Proposed Standard | March 2005 |
| 3821 | Fibre Channel Over TCP/IP (FCIP)M. Rajagopal, E. Rodriguez, R. Weber | Proposed Standard | July 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 3754 | IP Multicast in Differentiated Services (DS) NetworksR. Bless, K. Wehrle | Informational | April 2004 |
| 3747 | The Differentiated Services Configuration MIBH. Hazewinkel, Ed., D. Partain, Ed. | Proposed Standard | April 2004 |
| 3670 | Information Model for Describing Network Device QoS Datapath MechanismsB. Moore, D. Durham, J. Strassner, A. Westerinen, W. Weiss | Proposed Standard | January 2004 |
| 3662 | A Lower Effort Per-Domain Behavior (PDB) for Differentiated ServicesR. Bless, K. Nichols, K. Wehrle · obsoleted by RFC 8622 | Informational | December 2003 |
| 3654 | Requirements for Separation of IP Control and ForwardingH. Khosravi, Ed., T. Anderson, Ed. | Informational | December 2003 |
| 3644 | Policy Quality of Service (QoS) Information ModelY. Snir, Y. Ramberg, J. Strassner, R. Cohen, B. Moore | Proposed Standard | November 2003 |
| 3604 | Requirements for Adding Optical Support to the General Switch Management Protocol version 3 (GSMPv3)H. Khosravi, G. Kullgren, S. Shew, J. Sadler, A. Watanabe | Informational | October 2003 |
| 3564 | Requirements for Support of Differentiated Services-aware MPLS Traffic EngineeringF. Le Faucheur, W. Lai | Informational | July 2003 |
| 3551 | RTP Profile for Audio and Video Conferences with Minimal ControlH. Schulzrinne, S. Casner | Internet Standard | July 2003 |
| 3549 | Linux Netlink as an IP Services ProtocolJ. Salim, H. Khosravi, A. Kleen, A. Kuznetsov | Informational | July 2003 |
| 3512 | Configuring Networks and Devices with Simple Network Management Protocol (SNMP)M. MacFaden, D. Partain, J. Saperia, W. Tackabury | Informational | April 2003 |
| 3426 | General Architectural and Policy ConsiderationsS. Floyd | Informational | November 2002 |
| 3366 | Advice to link designers on link Automatic Repeat reQuest (ARQ)G. Fairhurst, L. Wood | Best Current Practice | September 2002 |
| 3334 | Policy-Based AccountingT. Zseby, S. Zander, C. Carle | Experimental | October 2002 |
| 3317 | Differentiated Services Quality of Service Policy Information BaseK. Chan, R. Sahita, S. Hahn, K. McCloghrie | Historic | March 2003 |
| 3308 | Layer Two Tunneling Protocol (L2TP) Differentiated Services ExtensionP. Calhoun, W. Luo, D. McPherson, K. Peirce | Proposed Standard | November 2002 |
| 3299 | Request for Comments Summary RFC Numbers 3200-3299S. Ginoza | Informational | December 2003 |
| 3290 | An Informal Management Model for Diffserv RoutersY. Bernet, S. Blake, D. Grossman, A. Smith | Informational | June 2002 |
| 3289 | Management Information Base for the Differentiated Services ArchitectureF. Baker, K. Chan, A. Smith | Proposed Standard | June 2002 |
| 3287 | Remote Monitoring MIB Extensions for Differentiated ServicesA. Bierman | Proposed Standard | July 2002 |
| 3272 | Overview and Principles of Internet Traffic EngineeringD. Awduche, A. Chiu, A. Elwalid, I. Widjaja, X. Xiao · obsoleted by RFC 9522 | Informational | May 2002 |
| 3270 | Multi-Protocol Label Switching (MPLS) Support of Differentiated ServicesF. Le Faucheur, Ed., L. Wu, B. Davie, S. Davari, P. Vaananen, R. Krishnan, P. Cheval, J. Heinanen | Proposed Standard | May 2002 |
| 3260 | New Terminology and Clarifications for DiffservD. Grossman | Informational | April 2002 |
| 3248 | A Delay Bound alternative revision of RFC 2598G. Armitage, B. Carpenter, A. Casati, J. Crowcroft, J. Halpern, B. Kumar, J. Schnizlein | Informational | March 2002 |
| 3246 | An Expedited Forwarding PHB (Per-Hop Behavior)B. Davie, A. Charny, J.C.R. Bennet, K. Benson, J.Y. Le Boudec, W. Courtney, S. Davari, V. Firoiu, D. Stiliadis | Proposed Standard | March 2002 |
| 3234 | Middleboxes: Taxonomy and IssuesB. Carpenter, S. Brim | Informational | February 2002 |
| 3213 | Applicability Statement for CR-LDPJ. Ash, M. Girish, E. Gray, B. Jamoussi, G. Wright | Informational | January 2002 |
| 3198 | Terminology for Policy-Based ManagementA. Westerinen, J. Schnizlein, J. Strassner, M. Scherling, B. Quinn, S. Herzog, A. Huynh, M. Carlson, J. Perry, S. Waldbusser | Informational | November 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3148 | A Framework for Defining Empirical Bulk Transfer Capacity MetricsM. Mathis, M. Allman | Informational | July 2001 |
| 3140 | Per Hop Behavior Identification CodesD. Black, S. Brim, B. Carpenter, F. Le Faucheur | Proposed Standard | June 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 3102 | Realm Specific IP: FrameworkM. Borella, J. Lo, D. Grabelsky, G. Montenegro | Experimental | October 2001 |
| 3086 | Definition of Differentiated Services Per Domain Behaviors and Rules for their SpecificationK. Nichols, B. Carpenter | Informational | April 2001 |
| 3084 | COPS Usage for Policy Provisioning (COPS-PR)K. Chan, J. Seligson, D. Durham, S. Gai, K. McCloghrie, S. Herzog, F. Reichmeyer, R. Yavatkar, A. Smith | Historic | March 2001 |
| 3036 | LDP SpecificationL. Andersson, P. Doolan, N. Feldman, A. Fredette, B. Thomas · obsoleted by RFC 5036 | Proposed Standard | January 2001 |
| 3002 | Overview of 2000 IAB Wireless Internetworking WorkshopD. Mitzel | Informational | December 2000 |
| 2998 | A Framework for Integrated Services Operation over Diffserv NetworksY. Bernet, P. Ford, R. Yavatkar, F. Baker, L. Zhang, M. Speer, R. Braden, B. Davie, J. Wroclawski, E. Felstaine | Informational | November 2000 |
| 2997 | Specification of the Null Service TypeY. Bernet, A. Smith, B. Davie | Proposed Standard | November 2000 |
| 2996 | Format of the RSVP DCLASS ObjectY. Bernet | Proposed Standard | November 2000 |
| 2990 | Next Steps for the IP QoS ArchitectureG. Huston | Informational | November 2000 |
| 2983 | Differentiated Services and TunnelsD. Black | Informational | October 2000 |
| 2963 | A Rate Adaptive Shaper for Differentiated ServicesO. Bonaventure, S. De Cnodder | Informational | October 2000 |
| 2924 | Accounting Attributes and Record FormatsN. Brownlee, A. Blount | Informational | September 2000 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 2902 | Overview of the 1998 IAB Routing WorkshopS. Deering, S. Hares, C. Perkins, R. Perlman | Informational | August 2000 |
| 2884 | Performance Evaluation of Explicit Congestion Notification (ECN) in IP NetworksJ. Hadi Salim, U. Ahmed | Informational | July 2000 |
| 2873 | TCP Processing of the IPv4 Precedence FieldX. Xiao, A. Hannan, V. Paxson, E. Crabbe · obsoleted by RFC 9293 | Proposed Standard | June 2000 |
| 2859 | A Time Sliding Window Three Colour Marker (TSWTCM)W. Fang, N. Seddigh, B. Nandy | Experimental | June 2000 |
| 2836 | Per Hop Behavior Identification CodesS. Brim, B. Carpenter, F. Le Faucheur · obsoleted by RFC 3140 | Proposed Standard | May 2000 |
| 2775 | Internet TransparencyB. Carpenter | Informational | February 2000 |
| 2698 | A Two Rate Three Color MarkerJ. Heinanen, R. Guerin | Informational | September 1999 |
| 2697 | A Single Rate Three Color MarkerJ. Heinanen, R. Guerin | Informational | September 1999 |
| 2598 | An Expedited Forwarding PHBV. Jacobson, K. Nichols, K. Poduri · obsoleted by RFC 3246 | Proposed Standard | June 1999 |
| 2597 | Assured Forwarding PHB GroupJ. Heinanen, F. Baker, W. Weiss, J. Wroclawski | Proposed Standard | June 1999 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |