| 7094 | Architectural Considerations of IP AnycastD. McPherson, D. Oran, D. Thaler, E. Osterweil | Informational | January 2014 |
| 5954 | Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261V. Gurbani, Ed., B. Carpenter, Ed., B. Tate, Ed. | Proposed Standard | August 2010 |
| 5118 | Session Initiation Protocol (SIP) Torture Test Messages for Internet Protocol Version 6 (IPv6)V. Gurbani, C. Boulton, R. Sparks | Informational | February 2008 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4903 | Multi-Link Subnet IssuesD. Thaler | Informational | June 2007 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 4392 | IP over InfiniBand (IPoIB) ArchitectureV. Kashyap | Informational | April 2006 |
| 4171 | Internet Storage Name Service (iSNS)J. Tseng, K. Gibbons, F. Travostino, C. Du Laney, J. Souza | Proposed Standard | September 2005 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3723 | Securing Block Storage Protocols over IPB. Aboba, J. Tseng, J. Walker, V. Rangan, F. Travostino | Proposed Standard | April 2004 |
| 3720 | Internet Small Computer Systems Interface (iSCSI)J. Satran, K. Meth, C. Sapuntzakis, M. Chadalapaka, E. Zeidner · obsoleted by RFC 7143 | Proposed Standard | April 2004 |
| 3675 | .sex Considered DangerousD. Eastlake 3rd | Informational | February 2004 |
| 3651 | Handle System Namespace and Service DefinitionS. Sun, S. Reilly, L. Lannom | Informational | November 2003 |
| 3620 | The TUNNEL ProfileD. New | Proposed Standard | October 2003 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 3530 | Network File System (NFS) version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 7530 | Proposed Standard | April 2003 |
| 3525 | Gateway Control Protocol Version 1C. Groves, Ed., M. Pantaleo, Ed., T. Anderson, Ed., T. Taylor, Ed. · obsoleted by RFC 5125 | Historic | June 2003 |
| 3513 | Internet Protocol Version 6 (IPv6) Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 4291 | Proposed Standard | April 2003 |
| 3493 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, J. McCann, W. Stevens | Informational | March 2003 |
| 3484 | Default Address Selection for Internet Protocol version 6 (IPv6)R. Draves · obsoleted by RFC 6724 | Proposed Standard | March 2003 |
| 3460 | Policy Core Information Model (PCIM) ExtensionsB. Moore, Ed. | Proposed Standard | January 2003 |
| 3435 | Media Gateway Control Protocol (MGCP) Version 1.0F. Andreasen, B. Foster | Informational | January 2003 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3314 | Recommendations for IPv6 in Third Generation Partnership Project (3GPP) StandardsM. Wasserman, Ed. | Informational | September 2002 |
| 3307 | Allocation Guidelines for IPv6 Multicast AddressesB. Haberman | Proposed Standard | September 2002 |
| 3306 | Unicast-Prefix-based IPv6 Multicast AddressesB. Haberman, D. Thaler | Proposed Standard | September 2002 |
| 3291 | Textual Conventions for Internet Network AddressesM. Daniele, B. Haberman, S. Routhier, J. Schoenwaelder · obsoleted by RFC 4001 | Proposed Standard | May 2002 |
| 3266 | Support for IPv6 in Session Description Protocol (SDP)S. Olson, G. Camarillo, A. B. Roach · obsoleted by RFC 4566 | Proposed Standard | July 2002 |
| 3259 | A Message Bus for Local CoordinationJ. Ott, C. Perkins, D. Kutscher | Informational | May 2002 |
| 3219 | Telephony Routing over IP (TRIP)J. Rosenberg, H. Salama, M. Squire | Proposed Standard | January 2002 |
| 3193 | Securing L2TP using IPsecB. Patel, B. Aboba, W. Dixon, G. Zorn, S. Booth | Proposed Standard | November 2001 |
| 3178 | IPv6 Multihoming Support at Site Exit RoutersJ. Hagino, H. Snyder | Informational | October 2001 |
| 3164 | The BSD Syslog ProtocolC. Lonvick · obsoleted by RFC 5424 | Informational | August 2001 |
| 3162 | RADIUS and IPv6B. Aboba, G. Zorn, D. Mitton | Proposed Standard | August 2001 |
| 3146 | Transmission of IPv6 Packets over IEEE 1394 NetworksK. Fujisawa, A. Onoe | Proposed Standard | October 2001 |
| 3123 | A DNS RR Type for Lists of Address Prefixes (APL RR)P. Koch | Experimental | June 2001 |
| 3111 | Service Location Protocol Modifications for IPv6E. Guttman | Proposed Standard | May 2001 |
| 3082 | Notification and Subscription for SLPJ. Kempf, J. Goldschmidt | Experimental | March 2001 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3050 | Common Gateway Interface for SIPJ. Lennox, H. Schulzrinne, J. Rosenberg | Informational | January 2001 |
| 3041 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves · obsoleted by RFC 4941 | Proposed Standard | January 2001 |
| 3015 | Megaco Protocol Version 1.0F. Cuervo, N. Greene, A. Rayhan, C. Huitema, B. Rosen, J. Segers · obsoleted by RFC 3525 | Proposed Standard | November 2000 |
| 2960 | Stream Control Transmission ProtocolR. Stewart, Q. Xie, K. Morneault, C. Sharp, H. Schwarzbauer, T. Taylor, I. Rytina, M. Kalla, L. Zhang, V. Paxson · obsoleted by RFC 4960 | Proposed Standard | October 2000 |
| 2928 | Initial IPv6 Sub-TLA ID AssignmentsR. Hinden, S. Deering, R. Fink, T. Hain | Informational | September 2000 |
| 2921 | 6BONE pTLA and pNLA Formats (pTLA)B. Fink | Informational | September 2000 |
| 2909 | The Multicast Address-Set Claim (MASC) ProtocolP. Radoslavov, D. Estrin, R. Govindan, M. Handley, S. Kumar, D. Thaler | Historic | September 2000 |
| 2894 | Router Renumbering for IPv6M. Crawford | Proposed Standard | August 2000 |
| 2893 | Transition Mechanisms for IPv6 Hosts and RoutersR. Gilligan, E. Nordmark · obsoleted by RFC 4213 | Proposed Standard | August 2000 |
| 2885 | Megaco Protocol version 0.8F. Cuervo, N. Greene, C. Huitema, A. Rayhan, B. Rosen, J. Segers · obsoleted by RFC 3015 | Historic | August 2000 |
| 2874 | DNS Extensions to Support IPv6 Address Aggregation and RenumberingM. Crawford, C. Huitema | Historic | July 2000 |
| 2868 | RADIUS Attributes for Tunnel Protocol SupportG. Zorn, D. Leifer, A. Rubens, J. Shriver, M. Holdrege, I. Goyret | Informational | June 2000 |
| 2851 | Textual Conventions for Internet Network AddressesM. Daniele, B. Haberman, S. Routhier, J. Schoenwaelder · obsoleted by RFC 3291 | Proposed Standard | June 2000 |
| 2828 | Internet Security GlossaryR. Shirey · obsoleted by RFC 4949 | Informational | May 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2780 | IANA Allocation Guidelines For Values In the Internet Protocol and Related HeadersS. Bradner, V. Paxson | Best Current Practice | March 2000 |
| 2772 | 6Bone Backbone Routing GuidelinesR. Rockell, R. Fink | Informational | February 2000 |
| 2766 | Network Address Translation - Protocol Translation (NAT-PT)G. Tsirtsis, P. Srisuresh · obsoleted by RFC 4966 | Historic | February 2000 |
| 2765 | Stateless IP/ICMP Translation Algorithm (SIIT)E. Nordmark · obsoleted by RFC 6145 | Proposed Standard | February 2000 |
| 2740 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy · obsoleted by RFC 5340 | Proposed Standard | December 1999 |
| 2732 | Format for Literal IPv6 Addresses in URL'sR. Hinden, B. Carpenter, L. Masinter · obsoleted by RFC 3986 | Proposed Standard | December 1999 |
| 2730 | Multicast Address Dynamic Client Allocation Protocol (MADCAP)S. Hanna, B. Patel, M. Shah | Proposed Standard | December 1999 |
| 2723 | SRL: A Language for Describing Traffic Flows and Specifying Actions for Flow GroupsN. Brownlee | Informational | October 1999 |
| 2720 | Traffic Flow Measurement: Meter MIBN. Brownlee | Proposed Standard | October 1999 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2590 | Transmission of IPv6 Packets over Frame Relay Networks SpecificationA. Conta, A. Malis, M. Mueller | Proposed Standard | May 1999 |
| 2561 | Base Definitions of Managed Objects for TN3270E Using SMIv2K. White, R. Moore | Proposed Standard | April 1999 |
| 2553 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, W. Stevens · obsoleted by RFC 3493 | Informational | March 1999 |
| 2546 | 6Bone Routing PracticeA. Durand, B. Buclin · obsoleted by RFC 2772 | Informational | March 1999 |
| 2545 | Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain RoutingP. Marques, F. Dupont | Proposed Standard | March 1999 |
| 2529 | Transmission of IPv6 over IPv4 Domains without Explicit TunnelsB. Carpenter, C. Jung | Proposed Standard | March 1999 |
| 2526 | Reserved IPv6 Subnet Anycast AddressesD. Johnson, S. Deering | Proposed Standard | March 1999 |
| 2497 | Transmission of IPv6 Packets over ARCnet NetworksI. Souvatzis | Proposed Standard | January 1999 |
| 2492 | IPv6 over ATM NetworksG. Armitage, P. Schulter, M. Jork | Proposed Standard | January 1999 |
| 2491 | IPv6 over Non-Broadcast Multiple Access (NBMA) networksG. Armitage, P. Schulter, M. Jork, G. Harter | Proposed Standard | January 1999 |
| 2472 | IP Version 6 over PPPD. Haskin, E. Allen · obsoleted by RFC 5072, RFC 5172 | Proposed Standard | December 1998 |
| 2471 | IPv6 Testing Address AllocationR. Hinden, R. Fink, J. Postel · obsoleted by RFC 3701 | Historic | December 1998 |
| 2470 | Transmission of IPv6 Packets over Token Ring NetworksM. Crawford, T. Narten, S. Thomas | Proposed Standard | December 1998 |
| 2467 | Transmission of IPv6 Packets over FDDI NetworksM. Crawford | Proposed Standard | December 1998 |
| 2464 | Transmission of IPv6 Packets over Ethernet NetworksM. Crawford | Proposed Standard | December 1998 |
| 2463 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering · obsoleted by RFC 4443 | Draft Standard | December 1998 |
| 2462 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten · obsoleted by RFC 4862 | Draft Standard | December 1998 |
| 2461 | Neighbor Discovery for IP Version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson · obsoleted by RFC 4861 | Draft Standard | December 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2428 | FTP Extensions for IPv6 and NATsM. Allman, S. Ostermann, C. Metz | Proposed Standard | September 1998 |
| 2375 | IPv6 Multicast Address AssignmentsR. Hinden, S. Deering | Informational | July 1998 |
| 2374 | An IPv6 Aggregatable Global Unicast Address FormatR. Hinden, M. O'Dell, S. Deering · obsoleted by RFC 3587 | Historic | July 1998 |