| 1155 | Structure and identification of management information for TCP/IP-based internetsM.T. Rose, K. McCloghrie | Internet Standard | May 1990 |
| 1157 | Simple Network Management Protocol (SNMP)J.D. Case, M. Fedor, M.L. Schoffstall, J. Davin | Historic | May 1990 |
| 1212 | Concise MIB definitionsM.T. Rose, K. McCloghrie | Internet Standard | March 1991 |
| 1573 | Evolution of the Interfaces Group of MIB-IIK. McCloghrie, F. Kastenholz · obsoleted by RFC 2233 | Proposed Standard | January 1994 |
| 1901 | Introduction to Community-based SNMPv2J. Case, K. McCloghrie, M. Rose, S. Waldbusser | Historic | January 1996 |
| 1902 | Structure of Management Information for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 2578 | Draft Standard | January 1996 |
| 1905 | Protocol Operations for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 3416 | Draft Standard | January 1996 |
| 1906 | Transport Mappings for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 3417 | Draft Standard | January 1996 |
| 1907 | Management Information Base for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 3418 | Draft Standard | January 1996 |
| 1908 | Coexistence between Version 1 and Version 2 of the Internet-standard Network Management FrameworkJ. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 2576 | Draft Standard | January 1996 |
| 1909 | An Administrative Infrastructure for SNMPv2K. McCloghrie, Ed. | Historic | February 1996 |
| 1910 | User-based Security Model for SNMPv2G. Waters, Ed. | Historic | February 1996 |
| 2028 | The Organizations Involved in the IETF Standards ProcessR. Hovey, S. Bradner · obsoleted by RFC 9281 | Best Current Practice | October 1996 |
| 2044 | UTF-8, a transformation format of Unicode and ISO 10646F. Yergeau · obsoleted by RFC 2279 | Informational | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2261 | An Architecture for Describing SNMP Management FrameworksD. Harrington, R. Presuhn, B. Wijnen · obsoleted by RFC 2271 | Proposed Standard | January 1998 |
| 2272 | Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)J. Case, D. Harrington, R. Presuhn, B. Wijnen · obsoleted by RFC 2572 | Proposed Standard | January 1998 |
| 2273 | SNMPv3 ApplicationsD. Levi, P. Meyer, B. Stewart · obsoleted by RFC 2573 | Proposed Standard | January 1998 |
| 2274 | User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)U. Blumenthal, B. Wijnen · obsoleted by RFC 2574 | Proposed Standard | January 1998 |
| 2275 | View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)B. Wijnen, R. Presuhn, K. McCloghrie · obsoleted by RFC 2575 | Proposed Standard | January 1998 |