| 9776 | Internet Group Management Protocol, Version 3B. Haberman, Ed. | Internet Standard | March 2025 |
| 9251 | Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Proxies for Ethernet VPN (EVPN)A. Sajassi, S. Thoria, M. Mishra, K. Patel, J. Drake, W. Lin | Proposed Standard | June 2022 |
| 9182 | A YANG Network Data Model for Layer 3 VPNsS. Barguil, O. Gonzalez de Dios, Ed., M. Boucadair, Ed., L. Munoz, A. Aguado | Proposed Standard | February 2022 |
| 9181 | A Common YANG Data Model for Layer 2 and Layer 3 VPNsS. Barguil, O. Gonzalez de Dios, Ed., M. Boucadair, Ed., Q. Wu | Proposed Standard | February 2022 |
| 9166 | A YANG Data Model for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) SnoopingH. Zhao, X. Liu, Y. Liu, A. Peter, M. Sivakumar | Proposed Standard | February 2022 |
| 8652 | A YANG Data Model for the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD)X. Liu, F. Guo, M. Sivakumar, P. McAllister, A. Peter | Proposed Standard | November 2019 |
| 8394 | Split Network Virtualization Edge (Split-NVE) Control-Plane RequirementsY. Li, D. Eastlake 3rd, L. Kreeger, T. Narten, D. Black | Informational | May 2018 |
| 8378 | Signal-Free Locator/ID Separation Protocol (LISP) MulticastV. Moreno, D. Farinacci | Experimental | May 2018 |
| 8114 | Delivery of IPv4 Multicast Services to IPv4 Clients over an IPv6 Multicast NetworkM. Boucadair, C. Qin, C. Jacquenet, Y. Lee, Q. Wang | Proposed Standard | March 2017 |
| 7450 | Automatic Multicast TunnelingG. Bumgardner | Proposed Standard | February 2015 |
| 7287 | Mobile Multicast Sender Support in Proxy Mobile IPv6 (PMIPv6) DomainsT. Schmidt, Ed., S. Gao, H. Zhang, M. Waehlisch | Experimental | June 2014 |
| 7256 | Multicast Control Extensions for the Access Node Control Protocol (ANCP)F. Le Faucheur, R. Maglione, T. Taylor | Proposed Standard | July 2014 |
| 7161 | Proxy Mobile IPv6 (PMIPv6) Multicast Handover Optimization by the Subscription Information Acquisition through the LMA (SIAL)LM. Contreras, CJ. Bernardos, I. Soto | Experimental | March 2014 |
| 7117 | Multicast in Virtual Private LAN Service (VPLS)R. Aggarwal, Ed., Y. Kamite, L. Fang, Y. Rekhter, C. Kodeboniya | Proposed Standard | February 2014 |
| 7028 | Multicast Mobility Routing Optimizations for Proxy Mobile IPv6JC. Zuniga, LM. Contreras, CJ. Bernardos, S. Jeon, Y. Kim | Experimental | September 2013 |
| 6224 | Base Deployment for Multicast Listener Support in Proxy Mobile IPv6 (PMIPv6) DomainsT. Schmidt, M. Waehlisch, S. Krishnan | Informational | April 2011 |
| 5790 | Lightweight Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Version 2 (MLDv2) ProtocolsH. Liu, W. Cao, H. Asaeda | Proposed Standard | February 2010 |
| 5519 | Multicast Group Membership Discovery MIBJ. Chesterfield, B. Haberman, Ed. | Proposed Standard | April 2009 |
| 5501 | Requirements for Multicast Support in Virtual Private LAN ServicesY. Kamite, Ed., Y. Wada, Y. Serbest, T. Morin, L. Fang | Informational | March 2009 |
| 5135 | IP Multicast Requirements for a Network Address Translator (NAT) and a Network Address Port Translator (NAPT)D. Wing, T. Eckert | Best Current Practice | February 2008 |
| 4834 | Requirements for Multicast in Layer 3 Provider-Provisioned Virtual Private Networks (PPVPNs)T. Morin, Ed. | Informational | April 2007 |
| 4607 | Source-Specific Multicast for IPH. Holbrook, B. Cain | Proposed Standard | August 2006 |
| 4605 | Internet Group Management Protocol (IGMP) / Multicast Listener Discovery (MLD)-Based Multicast Forwarding ("IGMP/MLD Proxying")B. Fenner, H. He, B. Haberman, H. Sandick | Proposed Standard | August 2006 |
| 4604 | Using Internet Group Management Protocol Version 3 (IGMPv3) and Multicast Listener Discovery Protocol Version 2 (MLDv2) for Source-Specific MulticastH. Holbrook, B. Cain, B. Haberman | Proposed Standard | August 2006 |
| 4541 | Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping SwitchesM. Christensen, K. Kimball, F. Solensky | Informational | May 2006 |
| 4045 | Extensions to Support Efficient Carrying of Multicast Traffic in Layer-2 Tunneling Protocol (L2TP)G. Bourdon | Experimental | April 2005 |
| 3918 | Methodology for IP Multicast BenchmarkingD. Stopp, B. Hickman | Informational | October 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3376 | Internet Group Management Protocol, Version 3B. Cain, S. Deering, I. Kouvelas, B. Fenner, A. Thyagarajan · obsoleted by RFC 9776 | Proposed Standard | October 2002 |
| 3353 | Overview of IP Multicast in a Multi-Protocol Label Switching (MPLS) EnvironmentD. Ooms, B. Sales, W. Livens, A. Acharya, F. Griffoul, F. Ansari | Informational | August 2002 |
| 3228 | IANA Considerations for IPv4 Internet Group Management Protocol (IGMP)B. Fenner · obsoleted by RFC 9778 | Best Current Practice | February 2002 |
| 3170 | IP Multicast Applications: Challenges and SolutionsB. Quinn, K. Almeroth | Informational | September 2001 |
| 2715 | Interoperability Rules for Multicast Routing ProtocolsD. Thaler | Informational | October 1999 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2362 | Protocol Independent Multicast-Sparse Mode (PIM-SM): Protocol SpecificationD. Estrin, D. Farinacci, A. Helmy, D. Thaler, S. Deering, M. Handley, V. Jacobson, C. Liu, P. Sharma, L. Wei · obsoleted by RFC 4601, RFC 5059 | Experimental | June 1998 |