| 9364 | DNS Security Extensions (DNSSEC)P. Hoffman | Best Current Practice | February 2023 |
| 8976 | Message Digest for DNS ZonesD. Wessels, P. Barber, M. Weinberg, W. Kumari, W. Hardaker | Proposed Standard | February 2021 |
| 7129 | Authenticated Denial of Existence in the DNSR. Gieben, W. Mekking | Informational | February 2014 |
| 4025 | A Method for Storing IPsec Keying Material in DNSM. Richardson | Proposed Standard | March 2005 |
| 3755 | Legacy Resolver Compatibility for Delegation Signer (DS)S. Weiler · obsoleted by RFC 4033, RFC 4034, RFC 4035 | Proposed Standard | May 2004 |
| 3192 | Minimal FAX address format in Internet MailC. Allocchio | Draft Standard | October 2001 |
| 3191 | Minimal GSTN address format in Internet MailC. Allocchio | Draft Standard | October 2001 |
| 2828 | Internet Security GlossaryR. Shirey · obsoleted by RFC 4949 | Informational | May 2000 |
| 2766 | Network Address Translation - Protocol Translation (NAT-PT)G. Tsirtsis, P. Srisuresh · obsoleted by RFC 4966 | Historic | February 2000 |
| 2693 | SPKI Certificate TheoryC. Ellison, B. Frantz, B. Lampson, R. Rivest, B. Thomas, T. Ylonen | Experimental | September 1999 |
| 2673 | Binary Labels in the Domain Name SystemM. Crawford · obsoleted by RFC 6891 | Historic | August 1999 |
| 2672 | Non-Terminal DNS Name RedirectionM. Crawford · obsoleted by RFC 6672 | Proposed Standard | August 1999 |
| 2626 | The Internet and the Millennium Problem (Year 2000)P. Nesser II | Informational | June 1999 |
| 2599 | Request for Comments Summary RFC Numbers 2500-2599A. DeLaCruz | Informational | March 2000 |
| 2541 | DNS Security Operational ConsiderationsD. Eastlake 3rd · obsoleted by RFC 4641 | Informational | March 1999 |
| 2535 | Domain Name System Security ExtensionsD. Eastlake 3rd · obsoleted by RFC 4033, RFC 4034, RFC 4035 | Proposed Standard | March 1999 |
| 2505 | Anti-Spam Recommendations for SMTP MTAsG. Lindberg | Best Current Practice | February 1999 |
| 2412 | The OAKLEY Key Determination ProtocolH. Orman | Informational | November 1998 |
| 2316 | Report of the IAB Security Architecture WorkshopS. Bellovin | Informational | April 1998 |
| 2308 | Negative Caching of DNS Queries (DNS NCACHE)M. Andrews | Proposed Standard | March 1998 |
| 2304 | Minimal FAX address format in Internet MailC. Allocchio · obsoleted by RFC 3192 | Proposed Standard | March 1998 |
| 2303 | Minimal PSTN address format in Internet MailC. Allocchio · obsoleted by RFC 3191 | Proposed Standard | March 1998 |
| 2230 | Key Exchange Delegation Record for the DNSR. Atkinson | Informational | November 1997 |
| 2219 | Use of DNS Aliases for Network ServicesM. Hamilton, R. Wright | Best Current Practice | October 1997 |
| 2196 | Site Security HandbookB. Fraser | Informational | September 1997 |
| 2181 | Clarifications to the DNS SpecificationR. Elz, R. Bush | Proposed Standard | July 1997 |
| 2163 | Using the Internet DNS to Distribute MIXER Conformant Global Address Mapping (MCGAM)C. Allocchio | Proposed Standard | January 1998 |
| 2154 | OSPF with Digital SignaturesS. Murphy, M. Badger, B. Wellington | Experimental | June 1997 |
| 2137 | Secure Domain Name System Dynamic UpdateD. Eastlake 3rd · obsoleted by RFC 3007 | Proposed Standard | April 1997 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 2101 | IPv4 Address Behaviour TodayB. Carpenter, J. Crowcroft, Y. Rekhter | Informational | February 1997 |