| 10049 | Roughtime: A Protocol for Rough Time SynchronizationW. Ladd, M. Dansarie | Experimental | October 2026 |
| 9923 | The FNV Non-Cryptographic Hash AlgorithmL. Noll, K. Vo, D. Eastlake 3rd, T. Hansen | Informational | February 2026 |
| 9880 | Semantic Definition Format (SDF) for Data and Interactions of ThingsM. Koster, Ed., C. Bormann, Ed., A. Keränen | Proposed Standard | January 2026 |
| 9862 | Path Computation Element Communication Protocol (PCEP) Extensions for Segment Routing (SR) Policy Candidate PathsM. Koldychev, S. Sivabalan, S. Sidor, C. Barth, S. Peng, H. Bidgoli | Proposed Standard | October 2025 |
| 9850 | The SSLKEYLOGFILE Format for TLSM. Thomson, Y. Rosomakho, H. Tschofenig | Informational | July 2026 |
| 9804 | Simple Public Key Infrastructure (SPKI) S-ExpressionsR. Rivest, D. Eastlake 3rd | Informational | June 2025 |
| 9720 | RFC Formats and VersionsP. Hoffman, H. Flanagan | Informational | January 2025 |
| 9682 | Updates to the Concise Data Definition Language (CDDL) GrammarC. Bormann | Proposed Standard | November 2024 |
| 9651 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp | Proposed Standard | September 2024 |
| 9636 | The Time Zone Information Format (TZif)A. Olson, P. Eggert, K. Murchison | Proposed Standard | October 2024 |
| 9535 | JSONPath: Query Expressions for JSONS. Gössner, Ed., G. Normington, Ed., C. Bormann, Ed. | Proposed Standard | February 2024 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9458 | Oblivious HTTPM. Thomson, C. A. Wood | Proposed Standard | January 2024 |
| 9423 | Constrained RESTful Environments (CoRE) Target Attributes RegistryC. Bormann | Informational | April 2024 |
| 9421 | HTTP Message SignaturesA. Backman, Ed., J. Richer, Ed., M. Sporny | Proposed Standard | February 2024 |
| 9402 | Concat NotationM. Basaglia, J. Bernards, J. Maas | Informational | 1 April 2023 |
| 9396 | OAuth 2.0 Rich Authorization RequestsT. Lodderstedt, J. Richer, B. Campbell | Proposed Standard | May 2023 |
| 9358 | Path Computation Element Communication Protocol (PCEP) Extensions for Establishing Relationships between Sets of Label Switched Paths and Virtual NetworksY. Lee, H. Zheng, D. Ceccarelli | Proposed Standard | February 2023 |
| 9337 | Generating Password-Based Keys Using the GOST AlgorithmsE. Karelina, Ed. | Informational | December 2022 |
| 9277 | On Stable Storage for Items in Concise Binary Object Representation (CBOR)M. Richardson, C. Bormann | Proposed Standard | August 2022 |
| 9271 | Uninterruptible Power Supply (UPS) Management Protocol -- Commands and ResponsesR. Price, Ed. | Informational | August 2022 |
| 9256 | Segment Routing Policy ArchitectureC. Filsfils, K. Talaulikar, Ed., D. Voyer, A. Bogdanov, P. Mattes | Proposed Standard | July 2022 |
| 9001 | Using TLS to Secure QUICM. Thomson, Ed., S. Turner, Ed. | Proposed Standard | May 2021 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 8915 | Network Time Security for the Network Time ProtocolD. Franke, D. Sibold, K. Teichel, M. Dansarie, R. Sundblad | Proposed Standard | September 2020 |
| 8907 | The Terminal Access Controller Access-Control System Plus (TACACS+) ProtocolT. Dahm, A. Ota, D.C. Medway Gash, D. Carrel, L. Grant | Informational | September 2020 |
| 8844 | Unknown Key-Share Attacks on Uses of TLS with the Session Description Protocol (SDP)M. Thomson, E. Rescorla | Proposed Standard | January 2021 |
| 8809 | Registries for Web Authentication (WebAuthn)J. Hodges, G. Mandyam, M. Jones | Informational | August 2020 |
| 8794 | Extensible Binary Meta LanguageS. Lhomme, D. Rice, M. Bunkus | Proposed Standard | July 2020 |
| 8772 | The China Mobile, Huawei, and ZTE Broadband Network Gateway (BNG) Simple Control and User Plane Separation Protocol (S-CUSP)S. Hu, D. Eastlake, F. Qin, T. Chua, D. Huang | Informational | May 2020 |
| 8765 | DNS Push NotificationsT. Pusateri, S. Cheshire | Proposed Standard | June 2020 |
| 8590 | Change Poll Extension for the Extensible Provisioning Protocol (EPP)J. Gould, K. Feher | Proposed Standard | May 2019 |
| 8536 | The Time Zone Information Format (TZif)A. Olson, P. Eggert, K. Murchison · obsoleted by RFC 9636 | Proposed Standard | February 2019 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8322 | Resource-Oriented Lightweight Information Exchange (ROLIE)J. Field, S. Banghart, D. Waltermire | Proposed Standard | February 2018 |
| 8266 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing NicknamesP. Saint-Andre | Proposed Standard | October 2017 |
| 8265 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and PasswordsP. Saint-Andre, A. Melnikov | Proposed Standard | October 2017 |
| 8264 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet | Proposed Standard | October 2017 |
| 8187 | Indicating Character Encoding and Language for HTTP Header Field ParametersJ. Reschke | Proposed Standard | September 2017 |
| 8142 | GeoJSON Text SequencesS. Gillies | Proposed Standard | April 2017 |
| 8141 | Uniform Resource Names (URNs)P. Saint-Andre, J. Klensin | Proposed Standard | April 2017 |
| 8011 | Internet Printing Protocol/1.1: Model and SemanticsM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 7997 | The Use of Non-ASCII Characters in RFCsH. Flanagan, Ed. | Informational | December 2016 |
| 7978 | Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Header ExtensionD. Eastlake 3rd, M. Umair, Y. Li | Proposed Standard | September 2016 |
| 7914 | The scrypt Password-Based Key Derivation FunctionC. Percival, S. Josefsson | Informational | August 2016 |
| 7797 | JSON Web Signature (JWS) Unencoded Payload OptionM. Jones | Proposed Standard | February 2016 |
| 7700 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing NicknamesP. Saint-Andre · obsoleted by RFC 8266 | Proposed Standard | December 2015 |
| 7636 | Proof Key for Code Exchange by OAuth Public ClientsN. Sakimura, Ed., J. Bradley, N. Agarwal | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7613 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and PasswordsP. Saint-Andre, A. Melnikov · obsoleted by RFC 8265 | Proposed Standard | August 2015 |
| 7569 | Registry Specification for Mandatory Access Control (MAC) Security Label FormatsD. Quigley, J. Lu, T. Haynes | Proposed Standard | July 2015 |
| 7565 | The 'acct' URI SchemeP. Saint-Andre | Proposed Standard | May 2015 |
| 7564 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet · obsoleted by RFC 8264 | Proposed Standard | May 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7519 | JSON Web Token (JWT)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7518 | JSON Web Algorithms (JWA)M. Jones | Proposed Standard | May 2015 |
| 7517 | JSON Web Key (JWK)M. Jones | Proposed Standard | May 2015 |
| 7516 | JSON Web Encryption (JWE)M. Jones, J. Hildebrand | Proposed Standard | May 2015 |
| 7515 | JSON Web Signature (JWS)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7514 | Really Explicit Congestion Notification (RECN)M. Luckie | Experimental | 1 April 2015 |
| 7495 | Enumeration Reference Format for the Incident Object Description Exchange Format (IODEF)A. Montville, D. Black | Proposed Standard | March 2015 |
| 7486 | HTTP Origin-Bound Authentication (HOBA)S. Farrell, P. Hoffman, M. Thomas | Experimental | March 2015 |
| 7464 | JavaScript Object Notation (JSON) Text SequencesN. Williams | Proposed Standard | February 2015 |
| 7259 | The Jabber-ID Header FieldP. Saint-Andre | Informational | May 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7210 | Database of Long-Lived Symmetric Cryptographic KeysR. Housley, T. Polk, S. Hartman, D. Zhang | Proposed Standard | April 2014 |
| 7012 | Information Model for IP Flow Information Export (IPFIX)B. Claise, Ed., B. Trammell, Ed. | Proposed Standard | September 2013 |
| 6963 | A Uniform Resource Name (URN) Namespace for ExamplesP. Saint-Andre | Best Current Practice | May 2013 |
| 6788 | The Line-Identification OptionS. Krishnan, A. Kavanagh, B. Varga, S. Ooghe, E. Nordmark | Proposed Standard | November 2012 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 5198 | Unicode Format for Network InterchangeJ. Klensin, M. Padlipsky | Proposed Standard | March 2008 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4627 | The application/json Media Type for JavaScript Object Notation (JSON)D. Crockford · obsoleted by RFC 7159 | Informational | July 2006 |
| 4592 | The Role of Wildcards in the Domain Name SystemE. Lewis | Proposed Standard | July 2006 |
| 3548 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson, Ed. · obsoleted by RFC 4648 | Informational | July 2003 |
| 1012 | Bibliography of Request For Comments 1 through 999J.K. Reynolds, J. Postel | Informational | June 1987 |
| 158 | Telnet Protocol: A Proposed DocumentT.C. O'Sullivan · obsoleted by RFC 495 | Unknown | May 1971 |
| 137 | Telnet Protocol - a proposed documentT.C. O'Sullivan | Unknown | April 1971 |
| 100 | Categorization and guide to NWG/RFCsP.M. Karp | Unknown | February 1971 |
| 84 | List of NWG/RFC's 1-80J.B. North | Unknown | December 1970 |