| 10003 | Certificate Management over CMS (CMC): Transport ProtocolsJ. Mandel, Ed., S. Turner, Ed. | Proposed Standard | July 2026 |
| 9811 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)H. Brockhaus, D. von Oheimb, M. Ounsworth, J. Gray | Proposed Standard | July 2025 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 8404 | Effects of Pervasive Encryption on OperatorsK. Moriarty, Ed., A. Morton, Ed. | Informational | July 2018 |
| 8170 | Planning for Protocol Adoption and Subsequent TransitionsD. Thaler, Ed. | Informational | May 2017 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7151 | File Transfer Protocol HOST Command for Virtual HostsP. Hethmon, R. McMurray | Proposed Standard | March 2014 |
| 6712 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)T. Kause, M. Peylo · obsoleted by RFC 9811 | Proposed Standard | September 2012 |
| 6202 | Known Issues and Best Practices for the Use of Long Polling and Streaming in Bidirectional HTTPS. Loreto, P. Saint-Andre, S. Salsano, G. Wilkins | Informational | April 2011 |
| 6101 | The Secure Sockets Layer (SSL) Protocol Version 3.0A. Freier, P. Karlton, P. Kocher | Historic | August 2011 |
| 5198 | Unicode Format for Network InterchangeJ. Klensin, M. Padlipsky | Proposed Standard | March 2008 |
| 4639 | Cable Device Management Information Base for Data-Over-Cable Service Interface Specification (DOCSIS) Compliant Cable Modems and Cable Modem Termination SystemsR. Woundy, K. Marez | Proposed Standard | December 2006 |
| 4413 | TCP/IP Field BehaviorM. West, S. McCann | Informational | March 2006 |
| 4229 | HTTP Header Field RegistrationsM. Nottingham, J. Mogul | Informational | December 2005 |
| 3875 | The Common Gateway Interface (CGI) Version 1.1D. Robinson, K. Coar | Informational | October 2004 |
| 3864 | Registration Procedures for Message Header FieldsG. Klyne, M. Nottingham, J. Mogul | Best Current Practice | September 2004 |
| 3805 | Printer MIB v2R. Bergman, H. Lewis, I. McDonald | Proposed Standard | June 2004 |
| 3760 | Securely Available Credentials (SACRED) - Credential Server FrameworkD. Gustafson, M. Just, M. Nystrom | Informational | April 2004 |
| 3675 | .sex Considered DangerousD. Eastlake 3rd | Informational | February 2004 |
| 3390 | Increasing TCP's Initial WindowM. Allman, S. Floyd, C. Partridge | Proposed Standard | November 2002 |
| 3229 | Delta encoding in HTTPJ. Mogul, B. Krishnamurthy, F. Douglis, A. Feldmann, Y. Goland, A. van Hoff, D. Hellerstein | Proposed Standard | January 2002 |
| 3117 | On the Design of Application ProtocolsM. Rose | Informational | November 2001 |
| 3040 | Internet Web Replication and Caching TaxonomyI. Cooper, I. Melve, G. Tomlinson | Informational | January 2001 |
| 2936 | HTTP MIME Type Handler DetectionD. Eastlake 3rd, C. Smith, D. Soroka | Informational | September 2000 |
| 2935 | Internet Open Trading Protocol (IOTP) HTTP SupplementD. Eastlake 3rd, C. Smith | Proposed Standard | September 2000 |
| 2896 | Remote Network Monitoring MIB Protocol Identifier MacrosA. Bierman, C. Bucci, R. Iddon | Informational | August 2000 |
| 2801 | Internet Open Trading Protocol - IOTP Version 1.0D. Burdett | Informational | April 2000 |
| 2774 | An HTTP Extension FrameworkH. Nielsen, P. Leach, S. Lawrence | Historic | February 2000 |
| 2617 | HTTP Authentication: Basic and Digest Access AuthenticationJ. Franks, P. Hallam-Baker, J. Hostetler, S. Lawrence, P. Leach, A. Luotonen, L. Stewart · obsoleted by RFC 7235, RFC 7615, RFC 7616, RFC 7617 | Draft Standard | June 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2594 | Definitions of Managed Objects for WWW ServicesH. Hazewinkel, C. Kalbfleisch, J. Schoenwaelder | Proposed Standard | May 1999 |
| 2557 | MIME Encapsulation of Aggregate Documents, such as HTML (MHTML)J. Palme, A. Hopmann, N. Shelness | Proposed Standard | March 1999 |
| 2414 | Increasing TCP's Initial WindowM. Allman, S. Floyd, C. Partridge · obsoleted by RFC 3390 | Experimental | September 1998 |
| 2299 | Request for Comments SummaryA. Ramos | Informational | January 1999 |
| 2295 | Transparent Content Negotiation in HTTPK. Holtman, A. Mutz | Experimental | March 1998 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2219 | Use of DNS Aliases for Network ServicesM. Hamilton, R. Wright | Best Current Practice | October 1997 |
| 2170 | Application REQuested IP over ATM (AREQUIPA)W. Almesberger, J. Le Boudec, P. Oechslin | Informational | July 1997 |
| 2169 | A Trivial Convention for using HTTP in URN ResolutionR. Daniel | Historic | June 1997 |
| 2151 | A Primer On Internet and TCP/IP Tools and UtilitiesG. Kessler, S. Shepard | Informational | June 1997 |
| 2145 | Use and Interpretation of HTTP Version NumbersJ. C. Mogul, R. Fielding, J. Gettys, H. Frystyk · obsoleted by RFC 7230 | Informational | May 1997 |
| 2142 | Mailbox Names for Common Services, Roles and FunctionsD. Crocker | Proposed Standard | May 1997 |
| 2130 | The Report of the IAB Character Set Workshop held 29 February - 1 March, 1996C. Weider, C. Preston, K. Simonsen, H. Alvestrand, R. Atkinson, M. Crispin, P. Svanberg | Informational | April 1997 |
| 2122 | VEMMI URL SpecificationD. Mavrakis, H. Layec, K. Kartmann | Proposed Standard | March 1997 |
| 2110 | MIME E-mail Encapsulation of Aggregate Documents, such as HTML (MHTML)J. Palme, A. Hopmann · obsoleted by RFC 2557 | Proposed Standard | March 1997 |
| 2084 | Considerations for Web Transaction SecurityG. Bossert, S. Cooper, W. Drummond | Informational | January 1997 |
| 2076 | Common Internet Message HeadersJ. Palme | Informational | February 1997 |
| 2074 | Remote Network Monitoring MIB Protocol IdentifiersA. Bierman, R. Iddon · obsoleted by RFC 2895 | Proposed Standard | January 1997 |
| 2069 | An Extension to HTTP : Digest Access AuthenticationJ. Franks, P. Hallam-Baker, J. Hostetler, P. Leach, A. Luotonen, E. Sink, L. Stewart · obsoleted by RFC 2617 | Proposed Standard | January 1997 |
| 2068 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T. Berners-Lee · obsoleted by RFC 2616 | Proposed Standard | January 1997 |