| 8892 | Guidelines and Registration Procedures for Interface Types and Tunnel TypesD. Thaler, D. Romascanu | Proposed Standard | August 2020 |
| 8096 | The IPv6-Specific MIB Modules Are ObsoleteB. Fenner | Informational | April 2017 |
| 6643 | Translation of Structure of Management Information Version 2 (SMIv2) MIB Modules to YANG ModulesJ. Schoenwaelder | Proposed Standard | July 2012 |
| 4181 | Guidelines for Authors and Reviewers of MIB DocumentsC. Heard, Ed. | Best Current Practice | September 2005 |
| 3418 | Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 2863 | The Interfaces Group MIBK. McCloghrie, F. Kastenholz | Draft Standard | June 2000 |
| 2741 | Agent Extensibility (AgentX) Protocol Version 1M. Daniele, B. Wijnen, M. Ellison, D. Francisco | Draft Standard | January 2000 |
| 2466 | Management Information Base for IP Version 6: ICMPv6 GroupD. Haskin, S. Onishi · obsoleted by RFC 4293, RFC 8096 | Historic | December 1998 |
| 2465 | Management Information Base for IP Version 6: Textual Conventions and General GroupD. Haskin, S. Onishi · obsoleted by RFC 4293, RFC 8096 | Historic | December 1998 |
| 2417 | Definitions of Managed Objects for Multicast over UNI 3.0/3.1 based ATM NetworksC. Chung, M. Greene | Proposed Standard | September 1998 |
| 2366 | Definitions of Managed Objects for Multicast over UNI 3.0/3.1 based ATM NetworksC. Chung, M. Greene · obsoleted by RFC 2417 | Proposed Standard | July 1998 |
| 2325 | Definitions of Managed Objects for Drip-Type Heated Beverage Hardware Devices using SMIv2M. Slavitch | Informational | 1 April 1998 |
| 2271 | An Architecture for Describing SNMP Management FrameworksD. Harrington, R. Presuhn, B. Wijnen · obsoleted by RFC 2571 | Proposed Standard | January 1998 |
| 2261 | An Architecture for Describing SNMP Management FrameworksD. Harrington, R. Presuhn, B. Wijnen · obsoleted by RFC 2271 | Proposed Standard | January 1998 |
| 2257 | Agent Extensibility (AgentX) Protocol Version 1M. Daniele, B. Wijnen, D. Francisco · obsoleted by RFC 2741 | Proposed Standard | January 1998 |
| 2233 | The Interfaces Group MIB using SMIv2K. McCloghrie, F. Kastenholz · obsoleted by RFC 2863 | Proposed Standard | November 1997 |
| 2128 | Dial Control Management Information Base using SMIv2G. Roeck, Ed. | Proposed Standard | March 1997 |
| 2127 | ISDN Management Information Base using SMIv2G. Roeck, Ed. | Proposed Standard | March 1997 |
| 2115 | Management Information Base for Frame Relay DTEs Using SMIv2C. Brown, F. Baker | Draft Standard | September 1997 |
| 2108 | Definitions of Managed Objects for IEEE 802.3 Repeater Devices using SMIv2K. de Graaf, D. Romascanu, D. McMaster, K. McCloghrie | Proposed Standard | February 1997 |
| 2037 | Entity MIB using SMIv2K. McCloghrie, A. Bierman · obsoleted by RFC 2737 | Proposed Standard | October 1996 |
| 2024 | Definitions of Managed Objects for Data Link Switching using SMIv2D. Chen, Ed., P. Gayek, S. Nix | Proposed Standard | October 1996 |
| 2021 | Remote Network Monitoring Management Information Base Version 2 using SMIv2S. Waldbusser · obsoleted by RFC 4502 | Proposed Standard | January 1997 |
| 2020 | IEEE 802.12 Interface MIBJ. Flick | Proposed Standard | October 1996 |
| 2011 | SNMPv2 Management Information Base for the Internet Protocol using SMIv2K. McCloghrie, Ed. · obsoleted by RFC 4293 | Proposed Standard | November 1996 |
| 2002 | IP Mobility SupportC. Perkins, Ed. · obsoleted by RFC 3220 | Proposed Standard | October 1996 |
| 1987 | Ipsilon's General Switch Management Protocol Specification Version 1.1P. Newman, W. Edwards, R. Hinden, E. Hoffman, F. Ching Liaw, T. Lyon, G. Minshall | Informational | August 1996 |
| 1909 | An Administrative Infrastructure for SNMPv2K. McCloghrie, Ed. | Historic | February 1996 |
| 1907 | Management Information Base for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 3418 | Draft Standard | January 1996 |
| 1902 | Structure of Management Information for Version 2 of the Simple Network Management Protocol (SNMPv2)J. Case, K. McCloghrie, M. Rose, S. Waldbusser · obsoleted by RFC 2578 | Draft Standard | January 1996 |
| 1757 | Remote Network Monitoring Management Information BaseS. Waldbusser · obsoleted by RFC 2819 | Draft Standard | February 1995 |
| 1748 | IEEE 802.5 MIB using SMIv2K. McCloghrie, E. Decker | Draft Standard | December 1994 |
| 1747 | Definitions of Managed Objects for SNA Data Link Control (SDLC) using SMIv2J. Hilgeman, S. Nix, A. Bartky, W. Clark, Ed. | Historic | January 1995 |
| 1743 | IEEE 802.5 MIB using SMIv2K. McCloghrie, E. Decker · obsoleted by RFC 1748 | Draft Standard | December 1994 |
| 1700 | Assigned NumbersJ. Reynolds, J. Postel · obsoleted by RFC 3232 | Historic | October 1994 |
| 1695 | Definitions of Managed Objects for ATM Management Version 8.0 using SMIv2M. Ahmed, Ed., K. Tesink, Ed. · obsoleted by RFC 2515 | Proposed Standard | August 1994 |
| 1694 | Definitions of Managed Objects for SMDS Interfaces using SMIv2T. Brown, Ed., K. Tesink, Ed. | Draft Standard | August 1994 |
| 1660 | Definitions of Managed Objects for Parallel-printer-like Hardware Devices using SMIv2B. Stewart | Draft Standard | July 1994 |
| 1659 | Definitions of Managed Objects for RS-232-like Hardware Devices using SMIv2B. Stewart | Draft Standard | July 1994 |
| 1658 | Definitions of Managed Objects for Character Stream Devices using SMIv2B. Stewart | Draft Standard | July 1994 |
| 1650 | Definitions of Managed Objects for the Ethernet-like Interface Types using SMIv2F. Kastenholz · obsoleted by RFC 2358 | Proposed Standard | August 1994 |
| 1643 | Definitions of Managed Objects for the Ethernet-like Interface TypesF. Kastenholz · obsoleted by RFC 3638 | Historic | July 1994 |
| 1623 | Definitions of Managed Objects for the Ethernet-like Interface TypesF. Kastenholz · obsoleted by RFC 1643 | Historic | May 1994 |
| 1604 | Definitions of Managed Objects for Frame Relay ServiceT. Brown, Ed. · obsoleted by RFC 2954 | Proposed Standard | March 1994 |
| 1596 | Definitions of Managed Objects for Frame Relay ServiceT. Brown, Ed. · obsoleted by RFC 1604 | Proposed Standard | March 1994 |
| 1595 | Definitions of Managed Objects for the SONET/SDH Interface TypeT. Brown, K. Tesink · obsoleted by RFC 2558 | Proposed Standard | March 1994 |