| 8881 | Network File System (NFS) Version 4 Minor Version 1 ProtocolD. Noveck, Ed., C. Lever | Proposed Standard | August 2020 |
| 8267 | Network File System (NFS) Upper-Layer Binding to RPC-over-RDMA Version 1C. Lever | Proposed Standard | October 2017 |
| 8166 | Remote Direct Memory Access Transport for Remote Procedure Call Version 1C. Lever, Ed., W. Simpson, T. Talpey | Proposed Standard | June 2017 |
| 7531 | Network File System (NFS) Version 4 External Data Representation Standard (XDR) DescriptionT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 5716 | Requirements for Federated File SystemsJ. Lentini, C. Everhart, D. Ellard, R. Tewari, M. Naik | Informational | January 2010 |
| 5667 | Network File System (NFS) Direct Data PlacementT. Talpey, B. Callaghan · obsoleted by RFC 8267 | Proposed Standard | January 2010 |
| 5666 | Remote Direct Memory Access Transport for Remote Procedure CallT. Talpey, B. Callaghan · obsoleted by RFC 8166 | Proposed Standard | January 2010 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5532 | Network File System (NFS) Remote Direct Memory Access (RDMA) Problem StatementT. Talpey, C. Juszczak | Informational | May 2009 |
| 5531 | RPC: Remote Procedure Call Protocol Specification Version 2R. Thurlow | Draft Standard | May 2009 |
| 3599 | Request for Comments Summary RFC Numbers 3500-3599S. Ginoza | Informational | December 2003 |
| 3530 | Network File System (NFS) version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 7530 | Proposed Standard | April 2003 |
| 3117 | On the Design of Application ProtocolsM. Rose | Informational | November 2001 |
| 3099 | Request for Comments Summary RFC Numbers 3000-3099S. Ginoza | Informational | November 2001 |
| 3010 | NFS version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 3530 | Proposed Standard | December 2000 |
| 2755 | Security Negotiation for WebNFSA. Chiu, M. Eisler, B. Callaghan | Informational | January 2000 |
| 2624 | NFS Version 4 Design ConsiderationsS. Shepler | Informational | June 1999 |
| 2623 | NFS Version 2 and Version 3 Security Issues and the NFS Protocol's Use of RPCSEC_GSS and Kerberos V5M. Eisler | Proposed Standard | June 1999 |
| 2224 | NFS URL SchemeB. Callaghan | Informational | October 1997 |
| 2055 | WebNFS Server SpecificationB. Callaghan | Informational | October 1996 |
| 2054 | WebNFS Client SpecificationB. Callaghan | Informational | October 1996 |
| 1983 | Internet Users' GlossaryG. Malkin, Ed. | Informational | August 1996 |
| 1813 | NFS Version 3 Protocol SpecificationB. Callaghan, B. Pawlowski, P. Staubach | Informational | June 1995 |
| 1392 | Internet Users' GlossaryG. Malkin, T. LaQuey Parker · obsoleted by RFC 1983 | Informational | January 1993 |