Skip to content
rfc.dk
Browse
STD
BCP
About
Cited in: RFC 10002
21 RFCs mentioned in the text of RFC 10002 (Certificate Management over CMS (CMC))
RFC
Title
Status
Date
2119
Key words for use in RFCs to Indicate Requirement Levels
S. Bradner
Best Current Practice
March 1997
2631
Diffie-Hellman Key Agreement Method
E. Rescorla
Proposed Standard
June 1999
2785
Methods for Avoiding the "Small-Subgroup" Attacks on the Diffie-Hellman Key Agreement Method for S/MIME
R. Zuccherato
Informational
March 2000
2797
Certificate Management Messages over CMS
M. Myers, X. Liu, J. Schaad, J. Weinstein · obsoleted by RFC 5272
Proposed Standard
April 2000
2986
PKCS #10: Certification Request Syntax Specification Version 1.7
M. Nystrom, B. Kaliski
Informational
November 2000
4086
Randomness Requirements for Security
D. Eastlake 3rd, J. Schiller, S. Crocker
Best Current Practice
June 2005
4211
Internet X.509 Public Key Infrastructure Certificate Request Message Format (CRMF)
J. Schaad
Proposed Standard
September 2005
5083
Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content Type
R. Housley
Proposed Standard
November 2007
5272
Certificate Management over CMS (CMC)
J. Schaad, M. Myers · obsoleted by RFC 10002
Proposed Standard
June 2008
5280
Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile
D. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk
Proposed Standard
May 2008
5652
Cryptographic Message Syntax (CMS)
R. Housley
Internet Standard
September 2009
5911
New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME
P. Hoffman, J. Schaad
Informational
June 2010
5912
New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)
P. Hoffman, J. Schaad
Informational
June 2010
6268
Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)
J. Schaad, S. Turner
Informational
July 2011
6402
Certificate Management over CMS (CMC) Updates
J. Schaad · obsoleted by RFC 10002, RFC 10003, RFC 10004
Proposed Standard
November 2011
6955
Diffie-Hellman Proof-of-Possession Algorithms
J. Schaad, H. Prafullchandra
Proposed Standard
May 2013
7841
RFC Streams, Headers, and Boilerplates
J. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.
Informational
May 2016
8174
Ambiguity of Uppercase vs Lowercase in RFC 2119 Key Words
B. Leiba
Best Current Practice
May 2017
9629
Using Key Encapsulation Mechanism (KEM) Algorithms in the Cryptographic Message Syntax (CMS)
R. Housley, J. Gray, T. Okubo
Proposed Standard
August 2024
10003
Certificate Management over CMS (CMC): Transport Protocols
J. Mandel, Ed., S. Turner, Ed.
Proposed Standard
July 2026
10004
Certificate Management over CMS (CMC): Compliance Requirements
J. Mandel, Ed., S. Turner, Ed.
Proposed Standard
July 2026
RFC 10002