| 5000 | Internet Official Protocol StandardsRFC Editor · obsoleted by RFC 7100 | Historic | May 2008 |
| 5001 | DNS Name Server Identifier (NSID) OptionR. Austein | Proposed Standard | August 2007 |
| 5002 | The Session Initiation Protocol (SIP) P-Profile-Key Private Header (P-Header)G. Camarillo, G. Blanco | Informational | August 2007 |
| 5003 | Attachment Individual Identifier (AII) Types for AggregationC. Metz, L. Martini, F. Balus, J. Sugimoto | Proposed Standard | September 2007 |
| 5004 | Avoid BGP Best Path Transitions from One External to AnotherE. Chen, S. Sangli | Proposed Standard | September 2007 |
| 5005 | Feed Paging and ArchivingM. Nottingham | Proposed Standard | September 2007 |
| 5006 | IPv6 Router Advertisement Option for DNS ConfigurationJ. Jeong, Ed., S. Park, L. Beloeil, S. Madanapalli · obsoleted by RFC 6106 | Experimental | September 2007 |
| 5007 | DHCPv6 LeasequeryJ. Brzozowski, K. Kinnear, B. Volz, S. Zeng | Proposed Standard | September 2007 |
| 5008 | Suite B in Secure/Multipurpose Internet Mail Extensions (S/MIME)R. Housley, J. Solinas · obsoleted by RFC 6318 | Historic | September 2007 |
| 5009 | Private Header (P-Header) Extension to the Session Initiation Protocol (SIP) for Authorization of Early MediaR. Ejzak | Informational | September 2007 |
| 5010 | The Dynamic Host Configuration Protocol Version 4 (DHCPv4) Relay Agent Flags SuboptionK. Kinnear, M. Normoyle, M. Stapp | Proposed Standard | September 2007 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 5012 | Requirements for Emergency Context Resolution with Internet TechnologiesH. Schulzrinne, R. Marshall, Ed. | Informational | January 2008 |
| 5013 | The Dublin Core Metadata Element SetJ. Kunze, T. Baker | Informational | August 2007 |
| 5014 | IPv6 Socket API for Source Address SelectionE. Nordmark, S. Chakrabarti, J. Laganier | Informational | September 2007 |
| 5015 | Bidirectional Protocol Independent Multicast (BIDIR-PIM)M. Handley, I. Kouvelas, T. Speakman, L. Vicisano | Proposed Standard | October 2007 |
| 5016 | Requirements for a DomainKeys Identified Mail (DKIM) Signing Practices ProtocolM. Thomas | Informational | October 2007 |
| 5017 | MIB Textual Conventions for Uniform Resource Identifiers (URIs)D. McWalter, Ed. | Proposed Standard | September 2007 |
| 5018 | Connection Establishment in the Binary Floor Control Protocol (BFCP)G. Camarillo | Proposed Standard | September 2007 |
| 5019 | The Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume EnvironmentsA. Deacon, R. Hurst · obsoleted by RFC 9919 | Proposed Standard | September 2007 |
| 5020 | The Lightweight Directory Access Protocol (LDAP) entryDN Operational AttributeK. Zeilenga | Proposed Standard | August 2007 |
| 5021 | Extended Kerberos Version 5 Key Distribution Center (KDC) Exchanges over TCPS. Josefsson | Proposed Standard | August 2007 |
| 5022 | Media Server Control Markup Language (MSCML) and ProtocolJ. Van Dyke, E. Burger, Ed., A. Spitzer | Informational | September 2007 |
| 5023 | The Atom Publishing ProtocolJ. Gregorio, Ed., B. de hOra, Ed. | Proposed Standard | October 2007 |
| 5024 | ODETTE File Transfer Protocol 2.0I. Friend | Informational | November 2007 |
| 5025 | Presence Authorization RulesJ. Rosenberg | Proposed Standard | December 2007 |
| 5026 | Mobile IPv6 Bootstrapping in Split ScenarioG. Giaretta, Ed., J. Kempf, V. Devarapalli, Ed. | Proposed Standard | October 2007 |
| 5027 | Security Preconditions for Session Description Protocol (SDP) Media StreamsF. Andreasen, D. Wing | Proposed Standard | October 2007 |
| 5028 | A Telephone Number Mapping (ENUM) Service Registration for Instant Messaging (IM) ServicesR. Mahy | Proposed Standard | October 2007 |
| 5029 | Definition of an IS-IS Link Attribute Sub-TLVJP. Vasseur, S. Previdi | Proposed Standard | September 2007 |
| 5030 | Mobile IPv4 RADIUS RequirementsM. Nakhjiri, Ed., K. Chowdhury, A. Lior, K. Leung | Informational | October 2007 |
| 5031 | A Uniform Resource Name (URN) for Emergency and Other Well-Known ServicesH. Schulzrinne | Proposed Standard | January 2008 |
| 5032 | WITHIN Search Extension to the IMAP ProtocolE. Burger, Ed. | Proposed Standard | September 2007 |
| 5033 | Specifying New Congestion Control AlgorithmsS. Floyd, M. Allman · obsoleted by RFC 9743 | Best Current Practice | August 2007 |
| 5034 | The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication MechanismR. Siemborski, A. Menon-Sen | Proposed Standard | July 2007 |
| 5035 | Enhanced Security Services (ESS) Update: Adding CertID Algorithm AgilityJ. Schaad | Proposed Standard | August 2007 |
| 5036 | LDP SpecificationL. Andersson, Ed., I. Minei, Ed., B. Thomas, Ed. | Draft Standard | October 2007 |
| 5037 | Experience with the Label Distribution Protocol (LDP)L. Andersson, Ed., I. Minei, Ed., B. Thomas, Ed. | Informational | October 2007 |
| 5038 | The Label Distribution Protocol (LDP) Implementation Survey ResultsB. Thomas, L. Andersson | Informational | October 2007 |
| 5039 | The Session Initiation Protocol (SIP) and SpamJ. Rosenberg, C. Jennings | Informational | January 2008 |
| 5040 | A Remote Direct Memory Access Protocol SpecificationR. Recio, B. Metzler, P. Culley, J. Hilland, D. Garcia | Proposed Standard | October 2007 |
| 5041 | Direct Data Placement over Reliable TransportsH. Shah, J. Pinkerton, R. Recio, P. Culley | Proposed Standard | October 2007 |
| 5042 | Direct Data Placement Protocol (DDP) / Remote Direct Memory Access Protocol (RDMAP) SecurityJ. Pinkerton, E. Deleganes | Proposed Standard | October 2007 |
| 5043 | Stream Control Transmission Protocol (SCTP) Direct Data Placement (DDP) AdaptationC. Bestler, Ed., R. Stewart, Ed. | Proposed Standard | October 2007 |
| 5044 | Marker PDU Aligned Framing for TCP SpecificationP. Culley, U. Elzur, R. Recio, S. Bailey, J. Carrier | Proposed Standard | October 2007 |
| 5045 | Applicability of Remote Direct Memory Access Protocol (RDMA) and Direct Data Placement (DDP)C. Bestler, Ed., L. Coene | Informational | October 2007 |
| 5046 | Internet Small Computer System Interface (iSCSI) Extensions for Remote Direct Memory Access (RDMA)M. Ko, M. Chadalapaka, J. Hufferd, U. Elzur, H. Shah, P. Thaler · obsoleted by RFC 7145 | Proposed Standard | October 2007 |
| 5047 | DA: Datamover Architecture for the Internet Small Computer System Interface (iSCSI)M. Chadalapaka, J. Hufferd, J. Satran, H. Shah | Informational | October 2007 |
| 5048 | Internet Small Computer System Interface (iSCSI) Corrections and ClarificationsM. Chadalapaka, Ed. · obsoleted by RFC 7143 | Proposed Standard | October 2007 |
| 5049 | Applying Signaling Compression (SigComp) to the Session Initiation Protocol (SIP)C. Bormann, Z. Liu, R. Price, G. Camarillo, Ed. | Proposed Standard | December 2007 |
| 5050 | Bundle Protocol SpecificationK. Scott, S. Burleigh | Experimental | November 2007 |
| 5051 | i;unicode-casemap - Simple Unicode Collation AlgorithmM. Crispin | Proposed Standard | October 2007 |
| 5052 | Forward Error Correction (FEC) Building BlockM. Watson, M. Luby, L. Vicisano | Proposed Standard | August 2007 |
| 5053 | Raptor Forward Error Correction Scheme for Object DeliveryM. Luby, A. Shokrollahi, M. Watson, T. Stockhammer | Proposed Standard | October 2007 |
| 5054 | Using the Secure Remote Password (SRP) Protocol for TLS AuthenticationD. Taylor, T. Wu, N. Mavrogiannopoulos, T. Perrin | Informational | November 2007 |
| 5055 | Server-Based Certificate Validation Protocol (SCVP)T. Freeman, R. Housley, A. Malpani, D. Cooper, W. Polk | Proposed Standard | December 2007 |
| 5056 | On the Use of Channel Bindings to Secure ChannelsN. Williams | Proposed Standard | November 2007 |
| 5057 | Multiple Dialog Usages in the Session Initiation ProtocolR. Sparks | Informational | November 2007 |
| 5058 | Explicit Multicast (Xcast) Concepts and OptionsR. Boivie, N. Feldman, Y. Imai, W. Livens, D. Ooms | Experimental | November 2007 |
| 5059 | Bootstrap Router (BSR) Mechanism for Protocol Independent Multicast (PIM)N. Bhaskar, A. Gall, J. Lingard, S. Venaas | Proposed Standard | January 2008 |
| 5060 | Protocol Independent Multicast MIBR. Sivaramu, J. Lingard, D. McWalter, B. Joshi, A. Kessler | Proposed Standard | January 2008 |
| 5061 | Stream Control Transmission Protocol (SCTP) Dynamic Address ReconfigurationR. Stewart, Q. Xie, M. Tuexen, S. Maruyama, M. Kozuka | Proposed Standard | September 2007 |
| 5062 | Security Attacks Found Against the Stream Control Transmission Protocol (SCTP) and Current CountermeasuresR. Stewart, M. Tuexen, G. Camarillo | Informational | September 2007 |
| 5063 | Extensions to GMPLS Resource Reservation Protocol (RSVP) Graceful RestartA. Satyanarayana, Ed., R. Rahman, Ed. | Proposed Standard | October 2007 |
| 5064 | The Archived-At Message Header FieldM. Duerst | Proposed Standard | December 2007 |
| 5065 | Autonomous System Confederations for BGPP. Traina, D. McPherson, J. Scudder | Draft Standard | August 2007 |
| 5066 | Ethernet in the First Mile Copper (EFMCu) Interfaces MIBE. Beili | Proposed Standard | November 2007 |
| 5067 | Infrastructure ENUM RequirementsS. Lind, P. Pfautz | Informational | November 2007 |
| 5068 | Email Submission Operations: Access and Accountability RequirementsC. Hutzler, D. Crocker, P. Resnick, E. Allman, T. Finch | Best Current Practice | November 2007 |
| 5069 | Security Threats and Requirements for Emergency Call Marking and MappingT. Taylor, Ed., H. Tschofenig, H. Schulzrinne, M. Shanmugam | Informational | January 2008 |
| 5070 | The Incident Object Description Exchange FormatR. Danyliw, J. Meijer, Y. Demchenko · obsoleted by RFC 7970 | Proposed Standard | December 2007 |
| 5071 | Dynamic Host Configuration Protocol Options Used by PXELINUXD. Hankins | Informational | December 2007 |
| 5072 | IP Version 6 over PPPS. Varada, Ed., D. Haskins, E. Allen | Draft Standard | September 2007 |
| 5073 | IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node CapabilitiesJ.P. Vasseur, Ed., J.L. Le Roux, Ed. | Proposed Standard | December 2007 |
| 5074 | DNSSEC Lookaside Validation (DLV)S. Weiler | Historic | November 2007 |
| 5075 | IPv6 Router Advertisement Flags OptionB. Haberman, Ed., R. Hinden · obsoleted by RFC 5175 | Proposed Standard | November 2007 |
| 5076 | ENUM Validation Information Mapping for the Extensible Provisioning ProtocolB. Hoeneisen | Proposed Standard | December 2007 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5078 | IAB and IESG Selection, Confirmation, and Recall Process: Revision of the Nominating and Recall Committees TimelineS. Dawkins · obsoleted by RFC 7437 | Informational | October 2007 |
| 5079 | Rejecting Anonymous Requests in the Session Initiation Protocol (SIP)J. Rosenberg | Proposed Standard | December 2007 |
| 5080 | Common Remote Authentication Dial In User Service (RADIUS) Implementation Issues and Suggested FixesD. Nelson, A. DeKok | Proposed Standard | December 2007 |
| 5081 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos · obsoleted by RFC 6091 | Experimental | November 2007 |
| 5082 | The Generalized TTL Security Mechanism (GTSM)V. Gill, J. Heasley, D. Meyer, P. Savola, Ed., C. Pignataro | Proposed Standard | October 2007 |
| 5083 | Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content TypeR. Housley | Proposed Standard | November 2007 |
| 5084 | Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | November 2007 |
| 5085 | Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for PseudowiresT. Nadeau, Ed., C. Pignataro, Ed. | Proposed Standard | December 2007 |
| 5086 | Structure-Aware Time Division Multiplexed (TDM) Circuit Emulation Service over Packet Switched Network (CESoPSN)A. Vainshtein, Ed., I. Sasson, E. Metz, T. Frost, P. Pate | Informational | December 2007 |
| 5087 | Time Division Multiplexing over IP (TDMoIP)Y(J). Stein, R. Shashoua, R. Insler, M. Anavi | Informational | December 2007 |
| 5088 | OSPF Protocol Extensions for Path Computation Element (PCE) DiscoveryJL. Le Roux, Ed., JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Proposed Standard | January 2008 |
| 5089 | IS-IS Protocol Extensions for Path Computation Element (PCE) DiscoveryJL. Le Roux, Ed., JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Proposed Standard | January 2008 |
| 5090 | RADIUS Extension for Digest AuthenticationB. Sterman, D. Sadolevsky, D. Schwartz, D. Williams, W. Beck | Proposed Standard | February 2008 |
| 5091 | Identity-Based Cryptography Standard (IBCS) #1: Supersingular Curve Implementations of the BF and BB1 CryptosystemsX. Boyen, L. Martin | Informational | December 2007 |
| 5092 | IMAP URL SchemeA. Melnikov, Ed., C. Newman | Proposed Standard | November 2007 |
| 5093 | BT's eXtended Network Quality RTP Control Protocol Extended Reports (RTCP XR XNQ)G. Hunt | Informational | December 2007 |
| 5094 | Mobile IPv6 Vendor Specific OptionV. Devarapalli, A. Patel, K. Leung | Proposed Standard | December 2007 |
| 5095 | Deprecation of Type 0 Routing Headers in IPv6J. Abley, P. Savola, G. Neville-Neil | Proposed Standard | December 2007 |
| 5096 | Mobile IPv6 Experimental MessagesV. Devarapalli | Proposed Standard | December 2007 |
| 5097 | MIB for the UDP-Lite protocolG. Renker, G. Fairhurst | Proposed Standard | January 2008 |
| 5098 | Signaling MIB for PacketCable and IPCablecom Multimedia Terminal Adapters (MTAs)G. Beacham, S. Kumar, S. Channabasappa | Proposed Standard | February 2008 |